summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-18 21:14:37 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-18 21:14:54 +0200
commitfaa91718d710261c140e1ff64ed0af187e685f02 (patch)
tree60857cc2567b4dd4452f870b66bbbd11322bd3bd /app-arch/afio
parentdev-libs/libpcre2: x86 stable (bug #617944) (diff)
downloadgentoo-faa91718d710261c140e1ff64ed0af187e685f02.tar.gz
gentoo-faa91718d710261c140e1ff64ed0af187e685f02.tar.bz2
gentoo-faa91718d710261c140e1ff64ed0af187e685f02.zip
app-arch/afio: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-arch/afio')
-rw-r--r--app-arch/afio/afio-2.5.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/afio/afio-2.5.1-r1.ebuild b/app-arch/afio/afio-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..e885c29a4304
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="cpio-format archives"
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+PATCHES=( "${FILESDIR}"/Makefile-r1.patch )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script$i"
+ dodoc "script$i"/*
+ done
+}