summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/arj/arj-3.10.22-r4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/arj/arj-3.10.22-r4.ebuild')
-rw-r--r--app-arch/arj/arj-3.10.22-r4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-arch/arj/arj-3.10.22-r4.ebuild b/app-arch/arj/arj-3.10.22-r4.ebuild
new file mode 100644
index 000000000000..b8cc5d8dae55
--- /dev/null
+++ b/app-arch/arj/arj-3.10.22-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils multilib toolchain-funcs
+
+PATCH_LEVEL=10
+
+DESCRIPTION="Utility for opening arj archives"
+HOMEPAGE="http://arj.sourceforge.net"
+SRC_URI="mirror://debian/pool/main/a/arj/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/a/arj/${P/-/_}-${PATCH_LEVEL}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-implicit-declarations.patch \
+ "${FILESDIR}/${P}-glibc2.10.patch"
+
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch "${WORKDIR}"/debian/patches
+
+ epatch "${FILESDIR}"/${P}-darwin.patch
+ epatch "${FILESDIR}"/${P}-interix.patch
+
+ cd gnu
+ eautoconf
+}
+
+src_configure() {
+ cd gnu
+ CFLAGS="${CFLAGS} -Wall" econf
+}
+
+src_compile() {
+ sed -i -e '/stripgcc/d' GNUmakefile || die "sed failed."
+
+ ARJLIBDIR="${EPREFIX}/usr/$(get_libdir)"
+
+ emake CC=$(tc-getCC) libdir="${ARJLIBDIR}" \
+ ADD_LDFLAGS="${LDFLAGS}" \
+ pkglibdir="${ARJLIBDIR}" all
+}
+
+src_install() {
+ emake pkglibdir="${ARJLIBDIR}" DESTDIR="${D}" install
+
+ dodoc doc/rev_hist.txt
+}