summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-15 20:48:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-15 20:48:42 +0200
commitb3327746703094e969ff44e1704e210f368c6236 (patch)
tree2f01acb54b36d922eef7b65f5a8fcccdf9c3fdc5 /app-arch/bzip3
parentprofiles/package.mask: unmask xdg-desktop-portal-{gnome,gtk} (diff)
downloadgentoo-b3327746703094e969ff44e1704e210f368c6236.tar.gz
gentoo-b3327746703094e969ff44e1704e210f368c6236.tar.bz2
gentoo-b3327746703094e969ff44e1704e210f368c6236.zip
app-arch/bzip3: bump to 1.1.2
use releases instead of tags so we do not have to fake .version/.tarball-version Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest1
-rw-r--r--app-arch/bzip3/bzip3-1.1.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index 744f1488a184..6e224d59c754 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1 +1,2 @@
DIST bzip3-1.1.1.tar.gz 2349860 BLAKE2B dd740b631b66db40bce35cccc0a46e4bbfe2a929aeaa2b083419e94cfcf3967c97fc6233e50fb1b0cb185ebd23bcad082567ca11ad5f0f037bdc4a95eb792f77 SHA512 22c7e415b2cd423b08a99051fd54bf0773e11a978559c9c382a4667087d6f1671de9ec564a5badbe1e8283aba83f5d1c70392ba7a0a96c8669ffee302d5d47e9
+DIST bzip3-1.1.2.tar.xz 256108 BLAKE2B a5f91fe2760fd4f7f79b908d735d613823dedac23e59950317c26f50d0a657dde042e5a08d401984c14d686d33726caa81e4b34cbca26e28c57a96f61e4f23ab SHA512 8b179bfe9b1b67c516580934cd12a640c86b3f9525c5e7902672051d80198cb91aa8880a4ca3ce14a879d26873405c713f1a0c6a33138d21f4d51c9e93d8fac5
diff --git a/app-arch/bzip3/bzip3-1.1.2.ebuild b/app-arch/bzip3/bzip3-1.1.2.ebuild
new file mode 100644
index 000000000000..4ccf8c7adedf
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}