summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 23:25:00 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-31 23:27:54 +0100
commit450b510f3e0d76ad2d183f463ac6447550736cdc (patch)
tree043293fa9b090b0c7140437025a0c56e0de1ea44 /app-arch/clzip/clzip-1.13.ebuild
parentdev-python/distro: Add pypy3 love (diff)
downloadgentoo-450b510f3e0d76ad2d183f463ac6447550736cdc.tar.gz
gentoo-450b510f3e0d76ad2d183f463ac6447550736cdc.tar.bz2
gentoo-450b510f3e0d76ad2d183f463ac6447550736cdc.zip
app-arch/clzip: Package one more lzip variant, v1.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/clzip/clzip-1.13.ebuild')
-rw-r--r--app-arch/clzip/clzip-1.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/clzip/clzip-1.13.ebuild b/app-arch/clzip/clzip-1.13.ebuild
new file mode 100644
index 000000000000..571001a3d9fe
--- /dev/null
+++ b/app-arch/clzip/clzip-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C language version of lzip"
+HOMEPAGE="https://www.nongnu.org/lzip/clzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/clzip/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CPPFLAGS="${CPPFLAGS}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}