summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-10 08:43:59 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-10 08:44:51 +0200
commit3dacec1af516a48faa03fa194102d60ac800c5fc (patch)
tree38d6875b24ecc6c42d1bd48b3b7c21188254b2f6 /app-arch/dpkg
parentnet-misc/s3cmd: version bump. (diff)
downloadgentoo-3dacec1af516a48faa03fa194102d60ac800c5fc.tar.gz
gentoo-3dacec1af516a48faa03fa194102d60ac800c5fc.tar.bz2
gentoo-3dacec1af516a48faa03fa194102d60ac800c5fc.zip
app-arch/dpkg: Version 1.19.2
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest1
-rw-r--r--app-arch/dpkg/dpkg-1.19.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
index 224d399150fa..e72db61bd907 100644
--- a/app-arch/dpkg/Manifest
+++ b/app-arch/dpkg/Manifest
@@ -1,2 +1,3 @@
DIST dpkg_1.19.0.5.tar.xz 4557428 BLAKE2B 99c31705bfad1cfa024366c788264f4e747a7143f87c581730797975303c1054003e41fd65ecf80df1dc053ba87c0e8449ec574ddcb158228b41ae57a23db18f SHA512 60d7198ffe6ea759c30ad82143b3107d41ce59224b853cb5a7beb79af0de6ba6a69414c365e6b3555a0a9c60e3cf9b543a3a448d80a734be38ccecb77ae963a9
DIST dpkg_1.19.1.tar.xz 4600848 BLAKE2B daadc95f0f66312e6012a5c9ce053dba055d87f766d8e9b9e99ed3eed59e83616b89cb2324fc61205bf4e22388cc0f9f62d191cbdd858250a50f7c6d141adf7d SHA512 d2c745f8cc3db94be15ce3ef74f9317768b316d9bb96aac2c681c2f47433524774e0c2d5ff3daf6e7cc779e5ffc4ce96783de12802f32dab1d72022786ca6c20
+DIST dpkg_1.19.2.tar.xz 4607868 BLAKE2B 4c191fb3dbe64bb3a515dadbb5f81bb32a0ae3b7267603978f7aee34f6baa02bacb818600759fe4bac0c3470ce2d6409c778a408833af796fe65f27fe910713f SHA512 244a6ef6aad935aee649503d6ce3238e34f4fae3f57ca79e99c1890140d913c29255bc9d0e90b50e96d2cf44ab0e44d6c3675a7bed306213fe5fe31710324cf7
diff --git a/app-arch/dpkg/dpkg-1.19.2.ebuild b/app-arch/dpkg/dpkg-1.19.2.ebuild
new file mode 100644
index 000000000000..aeee78ed9f49
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.19.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="https://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 libmd +lzma nls selinux static-libs test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.14.2:=
+ bzip2? ( app-arch/bzip2 )
+ libmd? ( app-crypt/libmd )
+ lzma? ( app-arch/xz-utils )
+ nls? ( virtual/libintl )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+DOCS=(
+ ChangeLog
+ THANKS
+ TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
+ "${FILESDIR}"/${PN}-1.18.12-flags.patch
+ "${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
+)
+
+src_prepare() {
+ use nls && strip-linguas -i po
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 libbz2) \
+ $(use_with libmd) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux libselinux) \
+ $(use_with zlib libz) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir \
+ /usr/$(get_libdir)/db/methods/{mnt,floppy,disk} \
+ /var/lib/dpkg/{alternatives,info,parts,updates}
+# /usr/$(get_libdir)/db/{alternatives,info,parts,updates} \
+
+ prune_libtool_files
+}