summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-27 07:22:54 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-27 07:22:54 +0200
commitd3810142c60d680d41b393db470552f9239e85e7 (patch)
treef5a3170f220c04e7589af90fcdb37b20eac49495 /app-arch/gzip/gzip-1.8.ebuild
parentdev-ruby/archive-tar-minitar: cleanup (diff)
downloadgentoo-d3810142c60d680d41b393db470552f9239e85e7.tar.gz
gentoo-d3810142c60d680d41b393db470552f9239e85e7.tar.bz2
gentoo-d3810142c60d680d41b393db470552f9239e85e7.zip
app-arch/gzip: Bump to version 1.8
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-arch/gzip/gzip-1.8.ebuild')
-rw-r--r--app-arch/gzip/gzip-1.8.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/gzip/gzip-1.8.ebuild b/app-arch/gzip/gzip-1.8.ebuild
new file mode 100644
index 000000000000..a6bdcdf07f26
--- /dev/null
+++ b/app-arch/gzip/gzip-1.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Standard GNU compressor"
+HOMEPAGE="https://www.gnu.org/software/gzip/"
+SRC_URI="mirror://gnu-alpha/gzip/${P}.tar.xz
+ mirror://gnu/gzip/${P}.tar.xz
+ mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="pic static"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.3.8-install-symlinks.patch"
+ "${FILESDIR}/${PN}-1.4-asmv.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ use static && append-flags -static
+ # avoid text relocation in gzip
+ use pic && export DEFS="NO_ASM"
+ econf
+}
+
+src_install() {
+ default
+ docinto txt
+ dodoc algorithm.doc gzip.doc
+
+ # keep most things in /usr, just the fun stuff in /
+ dodir /bin
+ mv "${ED}"/usr/bin/{gunzip,gzip,uncompress,zcat} "${ED}"/bin/ || die
+ sed -e "s:${EPREFIX}/usr:${EPREFIX}:" -i "${ED}"/bin/gunzip || die
+}