summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-25 13:39:00 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-25 13:40:45 +0200
commitcffb86da4495118b9bfd53d2cf8680358f746a6a (patch)
tree25b076d23edc6acdc1ee3ed08003b41dbbb28eac /app-arch/hardlink
parentapp-admin/kube-bench: Remove old (diff)
downloadgentoo-cffb86da4495118b9bfd53d2cf8680358f746a6a.tar.gz
gentoo-cffb86da4495118b9bfd53d2cf8680358f746a6a.tar.bz2
gentoo-cffb86da4495118b9bfd53d2cf8680358f746a6a.zip
app-arch/hardlink: Bump to version 0.3.2
which also builds against >=sys-apps/attr-2.4.48 Closes: https://bugs.gentoo.org/648628 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-arch/hardlink')
-rw-r--r--app-arch/hardlink/Manifest1
-rw-r--r--app-arch/hardlink/hardlink-0.3.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/hardlink/Manifest b/app-arch/hardlink/Manifest
index 60f39169593a..993a53629f21 100644
--- a/app-arch/hardlink/Manifest
+++ b/app-arch/hardlink/Manifest
@@ -1,2 +1,3 @@
+DIST hardlink-0.3.2.tar.bz2 15479 BLAKE2B dd6cfc312ed75dc6d9e37b898215ed90efe4734c5974297c9e29a51a69c9b2d4e91d9aa3bca1d42679307eecd95ee46e6f636c211d1ceafef1ea52428761d1ec SHA512 1d027f7b2f1974c950044fa8872dc58101800ca557a4d66406652fb43f64653f7dd39a70f4ac65f5f6bca9116de4ce44aeba2ef1fe446834641ba5c4c5604dff
DIST hardlink_0.2.0.tar.gz 12478 BLAKE2B 42918fbacdd230796e59f6ae7968599a90b63cc35876872ef34919377d6489c6c99d06f201a122f5859a283cea2672dbcc207e04c6b5ca0c54ab4e2f4178a970 SHA512 963fe90aa09e2bd548722b5c7f047fbd54fddf37967333e86251d7e5d1c646108ce90d78e7efeb8af6b9169b9a0bc5bc8b744afe1e813390f3e0bd535ce22005
DIST hardlink_0.3.0.tar.xz 14440 BLAKE2B cfbd02b008d49b129e0b75f67bf45d904e89a1e585d0e05e959770a4367ad0f5823f24cb4f3f6715310c749ba368ac00d378f8eb967a1b4437335eecee8a5077 SHA512 22a8945ce5dac74b05bb1231959823aec0cd364d6db9ad808df4acf232d894170c006ac1e88509604ce1859d41bd4a5d91e2b12c8010aa7fc7e19a77922c4486
diff --git a/app-arch/hardlink/hardlink-0.3.2.ebuild b/app-arch/hardlink/hardlink-0.3.2.ebuild
new file mode 100644
index 000000000000..7eca7686d2a2
--- /dev/null
+++ b/app-arch/hardlink/hardlink-0.3.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A tool which replaces copies of a file with hardlinks"
+HOMEPAGE="https://jak-linux.org/projects/hardlink/"
+#SRC_URI="https://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.xz"
+SRC_URI="https://salsa.debian.org/jak/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-libs/libpcre"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( README ${T}/README.rsync )
+
+src_prepare() {
+ default
+ sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
+
+ cat <<-EOF > "${T}"/README.rsync
+ https://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
+ for excluding rsync temporary files by default.
+
+ To accomplish same with this version, you can use following syntax:
+ # hardlink -x '^\..*\.\?{6,6}$'
+
+ This was discussed at https://bugs.gentoo.org/416613
+ EOF
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}