summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-20 14:47:51 +0000
committerSam James <sam@gentoo.org>2020-11-20 14:47:51 +0000
commit7320f67eb4dbc13d3f123a99948b9d2d02ad0a63 (patch)
treeeba082af5dd536a0f1dfa5a961aba9f38678e7a0 /app-arch/innoextract/innoextract-1.9.ebuild
parentdev-cpp/eigen: Stabilize 3.3.7-r1 amd64, #738380 (diff)
downloadgentoo-7320f67eb4dbc13d3f123a99948b9d2d02ad0a63.tar.gz
gentoo-7320f67eb4dbc13d3f123a99948b9d2d02ad0a63.tar.bz2
gentoo-7320f67eb4dbc13d3f123a99948b9d2d02ad0a63.zip
app-arch/innoextract: bump to 1.9
Bug: https://bugs.gentoo.org/738742 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/innoextract/innoextract-1.9.ebuild')
-rw-r--r--app-arch/innoextract/innoextract-1.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/innoextract/innoextract-1.9.ebuild b/app-arch/innoextract/innoextract-1.9.ebuild
new file mode 100644
index 000000000000..4067b8b4a685
--- /dev/null
+++ b/app-arch/innoextract/innoextract-1.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A tool to unpack installers created by Inno Setup"
+HOMEPAGE="https://constexpr.org/innoextract/"
+SRC_URI="https://constexpr.org/innoextract/files/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug +iconv +lzma"
+
+RDEPEND="
+ dev-libs/boost:=[bzip2,zlib]
+ iconv? ( virtual/libiconv )
+ lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.9-fix-linkage.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DDEBUG=$(usex debug)
+ -DSET_OPTIMIZATION_FLAGS=OFF
+ -DSTRICT_USE=ON
+ -DUSE_LZMA=$(usex lzma)
+ -DWITH_CONV=$(usex iconv iconv builtin)
+ )
+
+ cmake_src_configure
+}