summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-08-07 12:02:07 -0700
committerMatt Turner <mattst88@gentoo.org>2019-08-07 12:13:42 -0700
commitcec154c3438eee983aa3eccbb2c9ebc072d781b0 (patch)
treee7d009cfa72e082ebacbf67c18990e35a15bbc4d /app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
parentdev-db/mariadb-connector-c: bump to v3.1.3 (diff)
downloadgentoo-cec154c3438eee983aa3eccbb2c9ebc072d781b0.tar.gz
gentoo-cec154c3438eee983aa3eccbb2c9ebc072d781b0.tar.bz2
gentoo-cec154c3438eee983aa3eccbb2c9ebc072d781b0.zip
app-arch/lbzip2: Add patch to fix unaligned access
Also remove unnecessary eautoreconf since Whissi was nice enough to run make dist when he made the snapshot tarball. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild')
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
new file mode 100644
index 000000000000..7dc8fcd267ff
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3-s_isreg.patch
+ "${FILESDIR}"/${P}-fix-unaligned.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ dosym lbunzip2 /usr/bin/bunzip2
+ fi
+}