summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-09 16:45:27 -0500
committerAaron Bauman <bman@gentoo.org>2020-06-12 22:05:56 -0400
commit5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c (patch)
treece0c5bce0629052916b6410aeb383bd7650936b9 /app-arch/lha
parentdev-libs/tre: Security bump (diff)
downloadgentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.tar.gz
gentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.tar.bz2
gentoo-5fd34b6c421e0e5a88e92c303d6e0a67fc90b33c.zip
app-arch/lha: Security bump
Bug: https://bugs.gentoo.org/572418 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16155 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'app-arch/lha')
-rw-r--r--app-arch/lha/Manifest1
-rw-r--r--app-arch/lha/lha-114i_p20201004.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/lha/Manifest b/app-arch/lha/Manifest
index d2e59243e39f..695979b92d35 100644
--- a/app-arch/lha/Manifest
+++ b/app-arch/lha/Manifest
@@ -1 +1,2 @@
DIST lha-1.14i-ac20050924p1.tar.gz 285518 BLAKE2B 7e10ee4cfaeb7212f9dfbe254d33ec7b97bce41a042eed3d6f826790650f5059a19d2a334cc41a86112ba8d80904168a0b3c2785e7670577b2bda0b4d27f0dcc SHA512 efe43d407d273f8f724f7b205223bd122c76adac4b67ad5e9811e88cae03f1f3c3af4297aa6f24951a02558975bbafacf697e97ab0da578b4e0115b89237566f
+DIST lha-114i_p20201004.tar.gz 220541 BLAKE2B 64268deb40de67d5f4888f7d4b4529fa1b6ca02c562bd041d9edd1ac9cc74ccfa43198c79310bd354806e3095f6aba8c97256b49686feb8c713e3d8110137103 SHA512 9a9337cbb6a3d71253597750301e37163c5b495e712f2374adf2ac0d19f731ed49482a3f8b639e4c48c7ef6fa7ed9f9081516d77548e9c88ed3b9ac037efeb06
diff --git a/app-arch/lha/lha-114i_p20201004.ebuild b/app-arch/lha/lha-114i_p20201004.ebuild
new file mode 100644
index 000000000000..64f5b7ac288d
--- /dev/null
+++ b/app-arch/lha/lha-114i_p20201004.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_COMMIT="7c3cd95fdf0d2f9198bb779561724cd314bc39a6"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://github.com/jca02266/lha https://lha.osdn.jp"
+SRC_URI="https://github.com/jca02266/lha/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-file-list-from-stdin.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ dodoc olddoc/ChangeLog Hacking_of_LHa
+}