summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-24 18:32:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-24 18:32:22 +0100
commitf5ac2e62c29b654f971454917073c8879d4fb9a5 (patch)
treef3ffce2a5019ed3220d33a791a79f61383e789f0 /app-arch/lunzip
parentsys-fs/cryptsetup: add support for using detached LUKS headers (diff)
downloadgentoo-f5ac2e62c29b654f971454917073c8879d4fb9a5.tar.gz
gentoo-f5ac2e62c29b654f971454917073c8879d4fb9a5.tar.bz2
gentoo-f5ac2e62c29b654f971454917073c8879d4fb9a5.zip
app-arch/lunzip: New package, v1.13
Add lunzip, the standalone decompressor for the lzip format. This package is needed for the lzip suite to be more complete in Gentoo. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lunzip')
-rw-r--r--app-arch/lunzip/Manifest1
-rw-r--r--app-arch/lunzip/lunzip-1.13.ebuild27
-rw-r--r--app-arch/lunzip/metadata.xml8
3 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/lunzip/Manifest b/app-arch/lunzip/Manifest
new file mode 100644
index 000000000000..c52d5b73ad65
--- /dev/null
+++ b/app-arch/lunzip/Manifest
@@ -0,0 +1 @@
+DIST lunzip-1.13.tar.gz 66541 BLAKE2B 45b6a4ffaac6d9b8ddeeebe5e33609bf4e671ad7370570035bacf41ee8ad35f49e14f495dfba650de284fedca1a63ebafe7f67c18083b4add94caaf7709d8e2b SHA512 67f950883b7062d37601bc16d7d64c07f6c580afbf3c0f61394dd6fb5d41c27214484b1dea7aabd41db06d18162b95b5734674646c4fcc833268cabe8cba91bb
diff --git a/app-arch/lunzip/lunzip-1.13.ebuild b/app-arch/lunzip/lunzip-1.13.ebuild
new file mode 100644
index 000000000000..5c5c0ab1b983
--- /dev/null
+++ b/app-arch/lunzip/lunzip-1.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Decompressor for the lzip format, written in C"
+HOMEPAGE="https://www.nongnu.org/lzip/lunzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/lunzip/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}
diff --git a/app-arch/lunzip/metadata.xml b/app-arch/lunzip/metadata.xml
new file mode 100644
index 000000000000..076793e3f54b
--- /dev/null
+++ b/app-arch/lunzip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>