summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2021-04-16 19:27:50 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-04-18 08:00:35 +0300
commitfb17c6adb6997d89d57b6f0a6723998d535cdcd4 (patch)
tree004ad3033623d030c121fb1e4f5bc2a40e99779b /app-arch/lxqt-archiver
parentmedia-gfx/lximage-qt: add version 0.17.0 (diff)
downloadgentoo-fb17c6adb6997d89d57b6f0a6723998d535cdcd4.tar.gz
gentoo-fb17c6adb6997d89d57b6f0a6723998d535cdcd4.tar.bz2
gentoo-fb17c6adb6997d89d57b6f0a6723998d535cdcd4.zip
app-arch/lxqt-archiver: add version 0.4.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/lxqt-archiver')
-rw-r--r--app-arch/lxqt-archiver/Manifest1
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index bc4fe034a070..a1dd5e4959a0 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1 +1,2 @@
DIST lxqt-archiver-0.3.0.tar.xz 157492 BLAKE2B 05d9862c75cacf3b73670333a5b2dafb6abfcfd7433a1ebc3d27948122db875f892eb58a05221c880d1ac23530362ae4d9e7c6ebe0f06552b10bb903d51a6868 SHA512 840fae890611b081a1355ceb58ca65276784e6825822859ff2d6506190212268f1c67733dc94c65c9c5758f8d6a25c286c2b339356a50f29474b0c7ce2569d2c
+DIST lxqt-archiver-0.4.0.tar.xz 167124 BLAKE2B 2d9295200c284e2dc0c2b538a92952dd0a11882211e5d1d5838141583b4a595b65c26a057e5c9733190182a5f78958e15d0e086356d75dd4e0c72d3510a34cfc SHA512 e1b323cd118af3726009e153c4f9766ec53b29fa0280530da16e2101d36ec45b55de0fe3d87c1386a4e5b3d88712fd209659b4ebb9344af689812600ae136ed6
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild
new file mode 100644
index 000000000000..4bf9466ba805
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-libs/json-glib
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ >=x11-libs/libfm-qt-0.17.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}