summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-22 22:30:55 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-22 22:40:44 +0200
commitd4cc98e2df6e4f721eb28e6f0b1180d3356ef635 (patch)
tree46365a761a7a377310d18d3a90a5bf2e212ac4f0 /app-arch/lz4/lz4-1.8.2.ebuild
parentsys-apps/osinfo-db: bump to 20180514 (diff)
downloadgentoo-d4cc98e2df6e4f721eb28e6f0b1180d3356ef635.tar.gz
gentoo-d4cc98e2df6e4f721eb28e6f0b1180d3356ef635.tar.bz2
gentoo-d4cc98e2df6e4f721eb28e6f0b1180d3356ef635.zip
app-arch/lz4: Bump to 1.8.2
Closes: https://bugs.gentoo.org/656276
Diffstat (limited to 'app-arch/lz4/lz4-1.8.2.ebuild')
-rw-r--r--app-arch/lz4/lz4-1.8.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lz4/lz4-1.8.2.ebuild b/app-arch/lz4/lz4-1.8.2.ebuild
new file mode 100644
index 000000000000..0fc870435ede
--- /dev/null
+++ b/app-arch/lz4/lz4-1.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+SLOT="0/r131"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+}