summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 17:44:35 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 18:08:44 +0200
commitf58ffe8253d96095274403315067ee843cf6d8df (patch)
tree730854835e45d2522c74f51c98af69056e3a0f5d /app-arch/lzlib/lzlib-1.11.ebuild
parentdev-libs/openssl: test_ssl_new.t is known to fail with FEATURES=network-sandbox (diff)
downloadgentoo-f58ffe8253d96095274403315067ee843cf6d8df.tar.gz
gentoo-f58ffe8253d96095274403315067ee843cf6d8df.tar.bz2
gentoo-f58ffe8253d96095274403315067ee843cf6d8df.zip
app-arch/lzlib: Bump to 1.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch/lzlib/lzlib-1.11.ebuild')
-rw-r--r--app-arch/lzlib/lzlib-1.11.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/lzlib/lzlib-1.11.ebuild b/app-arch/lzlib/lzlib-1.11.ebuild
new file mode 100644
index 000000000000..b5c07f78748d
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.11.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="libstdc++" # fancy form of GPL-2+ with library exception
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ --disable-ldconfig
+ --prefix="${EPREFIX}"/usr
+ --libdir='$(prefix)'/$(get_libdir)
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}