summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/lzma
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/lzma')
-rw-r--r--app-arch/lzma/Manifest1
-rw-r--r--app-arch/lzma/lzma-9.20.ebuild35
-rw-r--r--app-arch/lzma/metadata.xml10
3 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/lzma/Manifest b/app-arch/lzma/Manifest
new file mode 100644
index 000000000000..6bcf400dc49b
--- /dev/null
+++ b/app-arch/lzma/Manifest
@@ -0,0 +1 @@
+DIST lzma920.tar.bz2 534077 SHA256 8ac221acdca8b6f6dd110120763af42b3707363752fc04e63c7bbff76774a445 SHA512 1c495530834107430a675fb48c006093edc301ec7a2c2f273efd62ff260f3056503bb2c3ddef63e82f5ff04b1347381055cf6cacd59eee9d451c4d841c13cd35 WHIRLPOOL 5ae0d8ece9d3d753ee3efa1b6422c15698a7f20d3783381cac7c5e10422ab532919018f44bac3050329745474c34b1115bc2006e70f4c6287600b89edca99db2
diff --git a/app-arch/lzma/lzma-9.20.ebuild b/app-arch/lzma/lzma-9.20.ebuild
new file mode 100644
index 000000000000..f9ecd55aacc1
--- /dev/null
+++ b/app-arch/lzma/lzma-9.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+S=${WORKDIR}
+
+src_compile() {
+ cd CPP/7zip/Bundles/LzmaCon
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon || die
+ dodoc lzma.txt history.txt
+ use doc && dodoc 7zC.txt 7zFormat.txt Methods.txt
+}
+
+pkg_postinst() {
+ einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
+}
diff --git a/app-arch/lzma/metadata.xml b/app-arch/lzma/metadata.xml
new file mode 100644
index 000000000000..8fbc72cbc106
--- /dev/null
+++ b/app-arch/lzma/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sevenzip</remote-id>
+ </upstream>
+</pkgmetadata>