summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-03-21 16:28:25 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-03-22 12:22:09 +0100
commitdb85f6bd42f42c0a1aec62ae080faf3fafaf6598 (patch)
treeaa576b5621d65c8f9b963531bb38a2c4463f1c9e /app-arch/qpress/qpress-1.1.ebuild
parentdev-vcs/subversion: add cygwin support (diff)
downloadgentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.tar.gz
gentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.tar.bz2
gentoo-db85f6bd42f42c0a1aec62ae080faf3fafaf6598.zip
app-arch/qpress: new package.
This package required as runtime dependency for dev-db/percona-xtrabackup. Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4270
Diffstat (limited to 'app-arch/qpress/qpress-1.1.ebuild')
-rw-r--r--app-arch/qpress/qpress-1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1.ebuild
new file mode 100644
index 000000000000..e7787c7973a5
--- /dev/null
+++ b/app-arch/qpress/qpress-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A portable file archiver using QuickLZ algorithm"
+HOMEPAGE="http://www.quicklz.com/"
+SRC_URI="http://www.quicklz.com/${PN}-${PV/./}-source.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Fix compilation with newer gcc
+ sed -i '1i #include <unistd.h>' qpress.cpp || die
+ cp "${FILESDIR}/makefile" "${S}" || die
+}
+
+src_install() {
+ dobin ${PN}
+}