summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/rpm/rpm-4.11.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/rpm/rpm-4.11.2-r1.ebuild')
-rw-r--r--app-arch/rpm/rpm-4.11.2-r1.ebuild120
1 files changed, 120 insertions, 0 deletions
diff --git a/app-arch/rpm/rpm-4.11.2-r1.ebuild b/app-arch/rpm/rpm-4.11.2-r1.ebuild
new file mode 100644
index 000000000000..31ff807f0216
--- /dev/null
+++ b/app-arch/rpm/rpm-4.11.2-r1.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils autotools flag-o-matic perl-module python-single-r1 versionator
+
+DESCRIPTION="Red Hat Package Management Utils"
+HOMEPAGE="http://www.rpm.org"
+SRC_URI="http://rpm.org/releases/rpm-$(get_version_component_range 1-2).x/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="nls python doc caps lua acl selinux"
+
+CDEPEND="!app-arch/rpm5
+ >=sys-libs/db-4.5
+ >=sys-libs/zlib-1.2.3-r1
+ >=app-arch/bzip2-1.0.1
+ >=dev-libs/popt-1.7
+ >=app-crypt/gnupg-1.2
+ dev-libs/elfutils
+ virtual/libintl
+ >=dev-lang/perl-5.8.8
+ dev-libs/nss
+ python? ( ${PYTHON_DEPS} )
+ nls? ( virtual/libintl )
+ lua? ( >=dev-lang/lua-5.1.0[deprecated] )
+ acl? ( virtual/acl )
+ caps? ( >=sys-libs/libcap-2.0 )"
+
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-rpm )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-4.11.0-autotools.patch \
+ "${FILESDIR}"/${PN}-4.8.1-db-path.patch \
+ "${FILESDIR}"/${PN}-4.9.1.2-libdir.patch
+
+ # fix #356769
+ sed -i 's:%{_var}/tmp:/var/tmp:' macros.in || die "Fixing tmppath failed"
+ # fix #492642
+ sed -i 's:@__PYTHON@:/usr/bin/python2:' macros.in || die "Fixing %__python failed"
+
+ eautoreconf
+
+ # Prevent automake maintainer mode from kicking in (#450448).
+ touch -r Makefile.am preinstall.am
+}
+
+src_configure() {
+ append-cppflags -I"${EPREFIX}/usr/include/nss" -I"${EPREFIX}/usr/include/nspr"
+ econf \
+ --without-selinux \
+ --with-external-db \
+ --without-beecrypt \
+ $(use_enable python) \
+ $(use_with doc hackingdocs) \
+ $(use_enable nls) \
+ $(use_with lua) \
+ $(use_with caps cap) \
+ $(use_with acl)
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ # remove la files
+ prune_libtool_files --all
+
+ mv "${ED}"/bin/rpm "${ED}"/usr/bin
+ rmdir "${ED}"/bin
+ # fix symlinks to /bin/rpm (#349840)
+ for binary in rpmquery rpmverify;do
+ ln -sf rpm "${ED}"/usr/bin/${binary}
+ done
+
+ use nls || rm -rf "${ED}"/usr/share/man/??
+
+ keepdir /usr/src/rpm/{SRPMS,SPECS,SOURCES,RPMS,BUILD}
+
+ dodoc CHANGES CREDITS GROUPS README*
+ if use doc; then
+ pushd doc/hacking/html
+ dohtml -p hacking -r .
+ popd
+ pushd doc/librpm/html
+ dohtml -p librpm -r .
+ popd
+ fi
+
+ # Fix perllocal.pod file collision
+ perl_delete_localpod
+}
+
+pkg_postinst() {
+ if [[ -f "${EROOT}"/var/lib/rpm/Packages ]] ; then
+ einfo "RPM database found... Rebuilding database (may take a while)..."
+ "${EROOT}"/usr/bin/rpmdb --rebuilddb --root="${EROOT}"
+ else
+ einfo "No RPM database found... Creating database..."
+ "${EROOT}"/usr/bin/rpmdb --initdb --root="${EROOT}"
+ fi
+}