summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 01:48:46 +0000
committerSam James <sam@gentoo.org>2021-04-07 01:57:41 +0000
commit223280966bd899718c85a616f8baa0376c8d84bb (patch)
tree1b9da4c0018330fd8c40f3f8d5913c26989082b6 /app-arch/rpm/rpm-4.16.0.ebuild
parentgames-arcade/epiar: ~amd64 keyworded for 0.5.1 (diff)
downloadgentoo-223280966bd899718c85a616f8baa0376c8d84bb.tar.gz
gentoo-223280966bd899718c85a616f8baa0376c8d84bb.tar.bz2
gentoo-223280966bd899718c85a616f8baa0376c8d84bb.zip
app-arch/rpm: make openmp optional
Closes: https://bugs.gentoo.org/779769 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/rpm/rpm-4.16.0.ebuild')
-rw-r--r--app-arch/rpm/rpm-4.16.0.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-arch/rpm/rpm-4.16.0.ebuild b/app-arch/rpm/rpm-4.16.0.ebuild
index 1742df61ac57..071d60b3c1df 100644
--- a/app-arch/rpm/rpm-4.16.0.ebuild
+++ b/app-arch/rpm/rpm-4.16.0.ebuild
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-2 )
PYTHON_COMPAT=( python3_{7,8,9} )
-inherit autotools flag-o-matic lua-single perl-module python-single-r1
+inherit autotools flag-o-matic lua-single perl-module python-single-r1 toolchain-funcs
DESCRIPTION="Red Hat Package Management Utils"
HOMEPAGE="https://rpm.org
@@ -20,7 +20,7 @@ KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~
# Tests are broken. See bug 657500
RESTRICT="test"
-IUSE="acl caps doc dbus lua nls python selinux test +zstd"
+IUSE="acl caps doc dbus lua nls openmp python selinux test +zstd"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -53,9 +53,15 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-rpm )
"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
use lua && lua-single_pkg_setup
use python && python-single-r1_pkg_setup
+
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
@@ -69,7 +75,6 @@ src_prepare() {
sed -i "s:@__PYTHON@:${PYTHON}:" macros.in || die "Fixing %__python failed"
eapply_user
-
eautoreconf
# Prevent automake maintainer mode from kicking in (#450448).
@@ -83,6 +88,7 @@ src_configure() {
--with-crypto=nss \
$(use_enable python) \
$(use_enable nls) \
+ $(use_enable openmp) \
$(use_enable dbus inhibit-plugin) \
$(use_with lua) \
$(use_with caps cap) \