summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-05-05 21:28:17 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 12:12:48 +0300
commita16aff822830ef6bd7bb40b14b5ad5853f155437 (patch)
tree5e2d9120abaf90cdde5b7ddbaa4a2c8a85ea08dd /app-arch/snappy/snappy-1.1.9.ebuild
parentdev-python/QtPy: add MissingUseDepDefault (diff)
downloadgentoo-a16aff822830ef6bd7bb40b14b5ad5853f155437.tar.gz
gentoo-a16aff822830ef6bd7bb40b14b5ad5853f155437.tar.bz2
gentoo-a16aff822830ef6bd7bb40b14b5ad5853f155437.zip
app-arch/snappy: update to 1.1.9
Taking maitainership, cleanup ebuild. Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20692 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/snappy/snappy-1.1.9.ebuild')
-rw-r--r--app-arch/snappy/snappy-1.1.9.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/snappy/snappy-1.1.9.ebuild b/app-arch/snappy/snappy-1.1.9.ebuild
new file mode 100644
index 000000000000..afb71c795daf
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.9.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://github.com/google/snappy"
+SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV%%.*}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-cpp/gtest )"
+
+DOCS=( format_description.txt framing_format.txt NEWS README.md )
+
+PATCHES=(
+ "${FILESDIR}/${P}_gcc_inline.patch"
+ "${FILESDIR}/${P}_external_gtest.patch"
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DSNAPPY_BUILD_TESTS=$(usex test)
+ -DSNAPPY_BUILD_BENCHMARKS=OFF
+ # we do not want to run benchmarks, and those are only used
+ # for benchmarks
+ -DHAVE_LIBZ=NO
+ -DHAVE_LIBLZO2=NO
+ -DHAVE_LIBLZ4=NO
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # run tests directly to get verbose output
+ cd "${S}" || die
+ "${BUILD_DIR}"/snappy_unittest || die
+}