summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-23 16:54:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-23 16:59:28 +0200
commit61a451b940e2eb57db4227c6dffc8ca0e13e24b1 (patch)
tree898ff28571fd01aaccb97c36b6c4c26c4b3c7f56 /app-arch/unar
parentkde-apps/ark: Improve rar archive postinst info (diff)
downloadgentoo-61a451b940e2eb57db4227c6dffc8ca0e13e24b1.tar.gz
gentoo-61a451b940e2eb57db4227c6dffc8ca0e13e24b1.tar.bz2
gentoo-61a451b940e2eb57db4227c6dffc8ca0e13e24b1.zip
app-arch/unar: EAPI 6, slot ops, sort deps, missing || die
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-arch/unar')
-rw-r--r--app-arch/unar/unar-1.10.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-arch/unar/unar-1.10.1.ebuild b/app-arch/unar/unar-1.10.1.ebuild
index b482d11dbaba..e81a5cd05425 100644
--- a/app-arch/unar/unar-1.10.1.ebuild
+++ b/app-arch/unar/unar-1.10.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit toolchain-funcs
@@ -14,20 +14,24 @@ SLOT="0"
KEYWORDS="amd64"
IUSE=""
-RDEPEND="gnustep-base/gnustep-base
+RDEPEND="
+ app-arch/bzip2:=
dev-libs/icu:=
- sys-libs/zlib
- app-arch/bzip2"
+ gnustep-base/gnustep-base
+ sys-libs/zlib:=
+"
DEPEND="${RDEPEND}
>=gnustep-base/gnustep-make-2.6.0[native-exceptions]
- sys-devel/gcc[objc]"
+ sys-devel/gcc[objc]
+"
S="${WORKDIR}/The Unarchiver/XADMaster"
src_prepare() {
+ default
# avoid jobserver warning, upstream bug:
# https://bitbucket.org/WAHa_06x36/theunarchiver/issues/918/dont-call-make-from-makefile
- sed -i -e 's:make:$(MAKE):g' Makefile.linux
+ sed -i -e 's:make:$(MAKE):g' Makefile.linux || die
}
src_compile() {