summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-25 11:02:56 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-25 11:03:19 -0400
commitf785bc8dda9a69b2e312fa88a6fc28ec2c2c44a8 (patch)
tree916ef86c90d8d9f1004c1bd6ab583cfc8c7a832f /app-arch/unshield/unshield-1.3.ebuild
parentwww-client/vivaldi: Version bump. (diff)
downloadgentoo-f785bc8dda9a69b2e312fa88a6fc28ec2c2c44a8.tar.gz
gentoo-f785bc8dda9a69b2e312fa88a6fc28ec2c2c44a8.tar.bz2
gentoo-f785bc8dda9a69b2e312fa88a6fc28ec2c2c44a8.zip
app-arch/unshield: new version 1.3.
Gentoo-Bug: 530664 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-arch/unshield/unshield-1.3.ebuild')
-rw-r--r--app-arch/unshield/unshield-1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/unshield/unshield-1.3.ebuild b/app-arch/unshield/unshield-1.3.ebuild
new file mode 100644
index 000000000000..04c2fbec0758
--- /dev/null
+++ b/app-arch/unshield/unshield-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+# OpenSSL (or LibreSSL) is detected at build time, and used to determine
+# whether or not a hand-rolled md5 implementation is used. The build
+# system prefers OpenSSL's implementation if it's available, and OpenSSL
+# is common enough, so we prefer it too. Since the dependency is
+# automagic (there's no way to hide it), we require Open/LibreSSL
+# unconditionally.
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+# Without this, the build fails looking for unshield_config.h.
+CMAKE_IN_SOURCE_BUILD=y