summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-04-28 14:10:01 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-04-28 14:10:01 +0200
commit23a6ff543e88639d4ee32b036cf60e5aa6b2d87b (patch)
treecc77c29c2791feacca8349caf2886abb27aeeecc /app-arch/unshield/unshield-1.4.2.ebuild
parentsys-libs/tdb: Removed old. (diff)
downloadgentoo-23a6ff543e88639d4ee32b036cf60e5aa6b2d87b.tar.gz
gentoo-23a6ff543e88639d4ee32b036cf60e5aa6b2d87b.tar.bz2
gentoo-23a6ff543e88639d4ee32b036cf60e5aa6b2d87b.zip
app-arch/unshield: Bump to version 1.4.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-arch/unshield/unshield-1.4.2.ebuild')
-rw-r--r--app-arch/unshield/unshield-1.4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/unshield/unshield-1.4.2.ebuild b/app-arch/unshield/unshield-1.4.2.ebuild
new file mode 100644
index 000000000000..1410d202234b
--- /dev/null
+++ b/app-arch/unshield/unshield-1.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+# OpenSSL (or LibreSSL) is detected at build time, and used to determine
+# whether or not a hand-rolled md5 implementation is used. The build
+# system prefers OpenSSL's implementation if it's available, and OpenSSL
+# is common enough, so we prefer it too. Since the dependency is
+# automagic (there's no way to hide it), we require Open/LibreSSL
+# unconditionally.
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"