summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2019-05-23 05:55:39 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-08-08 21:21:15 +0300
commit70ab4e4e37a23720a608fbeed7ca2e3f416fe36c (patch)
tree975a9f4441bfe4694290ba93ffce9a827fc4a90e /app-arch/upx/upx-3.95.ebuild
parentdev-libs/roct-thunk-interface: do not install Linux kernel headers (diff)
downloadgentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.tar.gz
gentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.tar.bz2
gentoo-70ab4e4e37a23720a608fbeed7ca2e3f416fe36c.zip
app-arch/upx: updated to 3.95
Updated to recent version 3.95 (#645646), removed -Werror option (#618432). Major cleanups to ebuild: * Updated to EAPI 7 * Updated HOMEPAGE, removed redundant USEs * Added myself to maintainers Closes: https://bugs.gentoo.org/618432 Closes: https://bugs.gentoo.org/645646 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/upx/upx-3.95.ebuild')
-rw-r--r--app-arch/upx/upx-3.95.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/upx/upx-3.95.ebuild b/app-arch/upx/upx-3.95.ebuild
new file mode 100644
index 000000000000..f0ea16873abd
--- /dev/null
+++ b/app-arch/upx/upx-3.95.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Ultimate Packer for eXecutables (free version using UCL compression and not NRV)"
+HOMEPAGE="http://upx.github.io/"
+SRC_URI="https://github.com/upx/upx/releases/download/v${PV}/${P}-src.tar.xz"
+
+LICENSE="GPL-2+ UPX-exception" # Read the exception before applying any patches
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/ucl-1.03
+ sys-libs/zlib
+ !app-arch/upx-bin"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}-src"
+
+src_compile() {
+ tc-export CXX
+ emake CXXFLAGS_WERROR="" all
+}
+
+src_install() {
+ newbin src/upx.out upx
+ dodoc BUGS NEWS PROJECTS README* THANKS doc/*.txt doc/upx.html
+ doman doc/upx.1
+}