summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-02 08:05:50 +0000
committerSam James <sam@gentoo.org>2021-03-02 08:40:15 +0000
commit1182b3f591cacb3555cd8b1783ddb6b8c0ad357e (patch)
treed010a770ad094040aae09b587047db5fb7f2ff1b /app-arch/vimball
parentdev-util/cookiecutter: add Python 3.9 (diff)
downloadgentoo-1182b3f591cacb3555cd8b1783ddb6b8c0ad357e.tar.gz
gentoo-1182b3f591cacb3555cd8b1783ddb6b8c0ad357e.tar.bz2
gentoo-1182b3f591cacb3555cd8b1783ddb6b8c0ad357e.zip
app-arch/vimball: add Python 3.9, use d_e_t pytest
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch/vimball')
-rw-r--r--app-arch/vimball/vimball-0.5.1.ebuild13
-rw-r--r--app-arch/vimball/vimball-9999.ebuild13
2 files changed, 8 insertions, 18 deletions
diff --git a/app-arch/vimball/vimball-0.5.1.ebuild b/app-arch/vimball/vimball-0.5.1.ebuild
index 2ad50ff8856c..1c9ba30f2f58 100644
--- a/app-arch/vimball/vimball-0.5.1.ebuild
+++ b/app-arch/vimball/vimball-0.5.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -19,11 +20,5 @@ HOMEPAGE="https://github.com/radhermit/vimball"
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index b5126bad3cf2..ee51ee899907 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -19,11 +20,5 @@ HOMEPAGE="https://github.com/radhermit/vimball"
LICENSE="MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests pytest