summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <someone@example.com>2021-07-11 10:28:28 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-16 09:00:09 +0300
commita752a165938b05d9046a0eb5341b197853ebbdac (patch)
treec913cda8dfa115987997f913be9761a3416a1c94 /app-arch/wimlib/wimlib-1.13.4.ebuild
parentsys-boot/woeusb: add myself as maintainer (diff)
downloadgentoo-a752a165938b05d9046a0eb5341b197853ebbdac.tar.gz
gentoo-a752a165938b05d9046a0eb5341b197853ebbdac.tar.bz2
gentoo-a752a165938b05d9046a0eb5341b197853ebbdac.zip
app-arch/wimlib: bump to 1.13.4
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Marco Scardovi <marco@scardovi.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-arch/wimlib/wimlib-1.13.4.ebuild')
-rw-r--r--app-arch/wimlib/wimlib-1.13.4.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/wimlib/wimlib-1.13.4.ebuild b/app-arch/wimlib/wimlib-1.13.4.ebuild
new file mode 100644
index 000000000000..20589458d689
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.13.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools pax-utils
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net"
+SRC_URI="https://wimlib.net/downloads/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
+SLOT="0"
+IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl test threads yasm"
+REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ cpu_flags_x86_ssse3? (
+ yasm? ( dev-lang/yasm )
+ !yasm? ( dev-lang/nasm )
+ )
+"
+RDEPEND="
+ dev-libs/libxml2:2
+ fuse? ( sys-fs/fuse:0 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+ ntfs? ( sys-fs/ntfs3g )
+ openssl? ( dev-libs/openssl:0= )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
+ $(use_with openssl libcrypto)
+ $(use_enable threads multithreaded-compression)
+ $(use_enable test test-support)
+ --disable-static
+ )
+ ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}