summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-01-01 19:45:28 +0100
committerSlawomir Lis <slis@gentoo.org>2019-01-01 19:45:28 +0100
commit4e7bd64df49223405cb0b477530ee4bd8d0f4b53 (patch)
treeee7f7a18d0c5fc092a06a608a2801bd58a6f2be4 /app-arch/wimlib
parentdev-vcs/hub: 2.7.0 version bump (diff)
downloadgentoo-4e7bd64df49223405cb0b477530ee4bd8d0f4b53.tar.gz
gentoo-4e7bd64df49223405cb0b477530ee4bd8d0f4b53.tar.bz2
gentoo-4e7bd64df49223405cb0b477530ee4bd8d0f4b53.zip
app-arch/wimlib: version bump to 1.13.0
closes: https://bugs.gentoo.org/674262 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'app-arch/wimlib')
-rw-r--r--app-arch/wimlib/Manifest1
-rw-r--r--app-arch/wimlib/wimlib-1.13.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
index 758e04021568..01df841c87a7 100644
--- a/app-arch/wimlib/Manifest
+++ b/app-arch/wimlib/Manifest
@@ -1 +1,2 @@
DIST wimlib-1.12.0.tar.gz 1014508 BLAKE2B d12f4e0b458fe756b74c67f2f643256c44021e0f0c3e2a3a70eb87647c3c6cabd93413917bf8a8c6ab6820860c407f4454454719227f5cbf1a9a81a7bedc1a6e SHA512 0343b37550366f07fd6a6689f4445f390187beddde677f4d6d831c07936d03b613ae95f612ec7a75e978a5e678f33ab766d0f3b3d942886df56e4ef77d4b07b9
+DIST wimlib-1.13.0.tar.gz 1035146 BLAKE2B 305d4bd4a0299c99b537c2bc59c674740239d3fe7c240038f4846849f36046ef587b04643d5a482c876668bf8f9a94a7b45a5e4f12c6d235a579a08c3879acff SHA512 a7ec729dda07b3884a851533a3c9e9db3061d9f6273ec318e40ece3687f4671f66989c07c080fa9cdcf5f01318c5eba7256b58f15f711b3ff14f4eb61c2114cb
diff --git a/app-arch/wimlib/wimlib-1.13.0.ebuild b/app-arch/wimlib/wimlib-1.13.0.ebuild
new file mode 100644
index 000000000000..9db9ef57d01a
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.13.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools pax-utils
+if [[ -z ${PV%%*9999} ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://wimlib.net/${PN}"
+else
+ inherit vcs-snapshot
+ MY_PV="${PV/_/-}"
+ MY_PV="${MY_PV^^}"
+ SRC_URI="https://wimlib.net/downloads/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+ RESTRICT="primaryuri"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net/"
+
+LICENSE="|| ( GPL-3+ LGPL-3+ ) CC0-1.0"
+SLOT="0"
+IUSE="cpu_flags_x86_ssse3 fuse iso ntfs openssl threads yasm"
+REQUIRED_USE="cpu_flags_x86_ssse3? ( !openssl )"
+
+PATCHES=( "${FILESDIR}/syslinux-path.patch" )
+
+RDEPEND="
+ dev-libs/libxml2:2
+ ntfs? ( sys-fs/ntfs3g )
+ fuse? ( sys-fs/fuse:0 )
+ openssl? ( dev-libs/openssl:0 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ cpu_flags_x86_ssse3? (
+ yasm? ( dev-lang/yasm )
+ !yasm? ( dev-lang/nasm )
+ )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable cpu_flags_x86_ssse3 ssse3-sha1)
+ $(use_with openssl libcrypto)
+ $(use_enable threads multithreaded-compression)
+ )
+ has test ${FEATURES} && myeconfargs+=( --enable-test-support )
+ ac_cv_prog_NASM="$(usex yasm yasm nasm)" \
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}