summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-01 22:56:10 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-01 23:11:52 +0100
commitb189900db0f38736c36898054584b2eb3ee0bbc2 (patch)
tree52a62ee3fb40e7e7b2a4f7a02ef2263f96019d67 /app-arch/zip/zip-3.0.ebuild
parentsys-apps/less: stable 529 for sparc, bug #643008 (diff)
downloadgentoo-b189900db0f38736c36898054584b2eb3ee0bbc2.tar.gz
gentoo-b189900db0f38736c36898054584b2eb3ee0bbc2.tar.bz2
gentoo-b189900db0f38736c36898054584b2eb3ee0bbc2.zip
app-arch/zip: Remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch/zip/zip-3.0.ebuild')
-rw-r--r--app-arch/zip/zip-3.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/app-arch/zip/zip-3.0.ebuild b/app-arch/zip/zip-3.0.ebuild
deleted file mode 100644
index 24708dc83140..000000000000
--- a/app-arch/zip/zip-3.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit toolchain-funcs eutils flag-o-matic
-
-MY_P="${PN}${PV//.}"
-DESCRIPTION="Info ZIP (encryption support)"
-HOMEPAGE="http://www.info-zip.org/"
-SRC_URI="mirror://sourceforge/infozip/${MY_P}.zip"
-
-LICENSE="Info-ZIP"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 crypt unicode"
-
-RDEPEND="bzip2? ( app-arch/bzip2 )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-3.0-no-crypt.patch #238398
- epatch "${FILESDIR}"/${PN}-3.0-pic.patch
- epatch "${FILESDIR}"/${PN}-3.0-exec-stack.patch
- epatch "${FILESDIR}"/${PN}-3.0-build.patch
-}
-
-src_compile() {
- use bzip2 || append-flags -DNO_BZIP2_SUPPORT
- use crypt || append-flags -DNO_CRYPT
- use unicode || append-flags -DNO_UNICODE_SUPPORT
- emake \
- CC="$(tc-getCC)" \
- LOCAL_ZIP="${CFLAGS} ${CPPFLAGS}" \
- -f unix/Makefile generic \
- || die
-}
-
-src_install() {
- dobin zip zipnote zipsplit || die
- doman man/zip{,note,split}.1
- if use crypt ; then
- dobin zipcloak || die
- doman man/zipcloak.1
- fi
- dodoc BUGS CHANGES README* TODO WHATSNEW WHERE proginfo/*.txt
-}