summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-19 22:13:39 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-19 22:27:58 -0400
commitcb21070a45e736d674aede6991df0b6da7cded63 (patch)
tree27c7b7892c11aeaeadc8af68dbaee8587a817539 /app-arch/zopfli/zopfli-1.0.1-r2.ebuild
parentdev-util/rebar: stabilize 2.6.1 on amd64/x86, bug #587914 (diff)
downloadgentoo-cb21070a45e736d674aede6991df0b6da7cded63.tar.gz
gentoo-cb21070a45e736d674aede6991df0b6da7cded63.tar.bz2
gentoo-cb21070a45e736d674aede6991df0b6da7cded63.zip
app-arch/zopfli: link binaries against installed libraries
Also install headers so the installed libraries are actually useful to third party builds.
Diffstat (limited to 'app-arch/zopfli/zopfli-1.0.1-r2.ebuild')
-rw-r--r--app-arch/zopfli/zopfli-1.0.1-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-arch/zopfli/zopfli-1.0.1-r2.ebuild b/app-arch/zopfli/zopfli-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..3d155dcde2f4
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/google/zopfli/"
+SRC_URI="https://github.com/google/zopfli/archive/${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( CONTRIBUTORS README README.zopflipng )
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+# zopflipng statically links an exact version of LodePNG (https://github.com/lvandeve/lodepng)
+
+src_prepare() {
+ default
+ tc-export CC CXX
+}
+
+# The Makefile has no install phase
+src_install() {
+ dolib.so libzopfli.so*
+ doheader src/zopfli/zopfli.h
+
+ dobin ${PN}
+
+ # This version was erroneously not bumped to match ${PV}
+ dolib.so libzopflipng.so*
+ doheader src/zopflipng/zopflipng_lib.h
+
+ dobin zopflipng
+}