summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2023-12-30 17:41:44 +0100
committerPetr Vaněk <arkamar@gentoo.org>2023-12-30 17:56:06 +0100
commit01927fc69d4c7a056d1886c1451416535480405f (patch)
treeb88705495c851a51566727e2513740d22e76de82 /app-arch
parentapp-arch/pdv: reconfigure also project root (diff)
downloadgentoo-01927fc69d4c7a056d1886c1451416535480405f.tar.gz
gentoo-01927fc69d4c7a056d1886c1451416535480405f.tar.bz2
gentoo-01927fc69d4c7a056d1886c1451416535480405f.zip
app-arch/pdv: resolve implicit function declaration issue
The issue is fixed with a patch which adds function prototype to a common header file. Closes: https://bugs.gentoo.org/882157 Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/pdv/files/pdv-1.5.1-missing-prototype.patch19
-rw-r--r--app-arch/pdv/pdv-1.5.1-r5.ebuild (renamed from app-arch/pdv/pdv-1.5.1-r4.ebuild)2
2 files changed, 21 insertions, 0 deletions
diff --git a/app-arch/pdv/files/pdv-1.5.1-missing-prototype.patch b/app-arch/pdv/files/pdv-1.5.1-missing-prototype.patch
new file mode 100644
index 000000000000..d35ddedfda74
--- /dev/null
+++ b/app-arch/pdv/files/pdv-1.5.1-missing-prototype.patch
@@ -0,0 +1,19 @@
+Add missing prototype to a common header file.
+
+Bug: https://bugs.gentoo.org/882157
+
+diff --git a/X11/xmpdvmkpkg.h b/X11/xmpdvmkpkg.h
+index abaaa47..fd6c6f5 100644
+--- a/X11/xmpdvmkpkg.h
++++ b/X11/xmpdvmkpkg.h
+@@ -76,6 +76,7 @@ extern Widget g_statusw;
+ void spectowidgets(void);
+ void widgetstospec(struct pdvspec_st *spec);
+ int cmpspecandwidgets(void);
++void statusmsg(char *fmt, ...);
+ void xu_SetMainTitle(const char *newtitle, const char *newprefix
+ , Widget topshell);
+
+--
+2.41.0
+
diff --git a/app-arch/pdv/pdv-1.5.1-r4.ebuild b/app-arch/pdv/pdv-1.5.1-r5.ebuild
index d77acc17e472..25fb97f0c2bc 100644
--- a/app-arch/pdv/pdv-1.5.1-r4.ebuild
+++ b/app-arch/pdv/pdv-1.5.1-r5.ebuild
@@ -34,6 +34,8 @@ PATCHES=(
"${FILESDIR}"/${P}-default-args.patch
# prevent pre-stripped binaries
"${FILESDIR}"/${P}-no-strip.patch
+ # missing function prototype, see bug #882157
+ "${FILESDIR}"/${P}-missing-prototype.patch
)
src_prepare() {