summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2021-06-05 00:29:39 -0400
committerMike Frysinger <vapier@gentoo.org>2021-06-05 00:29:39 -0400
commit06b8bbbcac843e8186608c0a45f34781a93b09e0 (patch)
tree4756547b6f3e12a9eb51f7347519ddbd964ff34b /app-arch
parentsys-libs/freeipmi: keyword 1.6.8 for ~ppc64 (diff)
downloadgentoo-06b8bbbcac843e8186608c0a45f34781a93b09e0.tar.gz
gentoo-06b8bbbcac843e8186608c0a45f34781a93b09e0.tar.bz2
gentoo-06b8bbbcac843e8186608c0a45f34781a93b09e0.zip
app-arch/makeself: version bump to 2.4.4
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/makeself/Manifest1
-rw-r--r--app-arch/makeself/makeself-2.4.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/makeself/Manifest b/app-arch/makeself/Manifest
index c7e58feec235..159a45ffdd5c 100644
--- a/app-arch/makeself/Manifest
+++ b/app-arch/makeself/Manifest
@@ -1,2 +1,3 @@
DIST makeself-2.4.3.tar.gz 32613 BLAKE2B 2295b6d47a8105f2b495260abb0c9ae85875c821d0291a19b5af894c1cef669f338c4e10de8128fe38008e7e08079d1f29949884f202cab680c7fd62e2f00dd9 SHA512 d404c7920c7f69ae29c7168bcf76806b6e2aae2e8916bb7feed998d031ce8b2cd205b83ad960a90b01189c97f9242eb3ef574194ba3ee51c605fe99dafbd6c13
+DIST makeself-2.4.4.tar.gz 38889 BLAKE2B eac74fa28ac39cbc6b18d11671bfa32d6c0b04b55b3603c6c928483dd64af38d416936ef242f55aa4840affd4bf7fb91c2987f87afab093816331e50f16379ab SHA512 3d4d03458f7f11a8df46340d1b489ca60d413d5ed857cc67bb8ef15335ce2848e4675e080791c26fdf29423f813d468b4b797438fe0876dad54e85c6346b9b8b
DIST release-2.2.0.tar.gz 21640 BLAKE2B 32b06157829864918d225a136043a5c9b7c6c543351e981c0e3cdce84cbbe4c52f00870bb04d29bfd79e715c1c708b51cc9958d495a9633afb9a8d342601c20d SHA512 11cd536baed2d56405103f18a8318a202092755a74baf10730aa58dc57032e327697b1c7f76bf9bf438927093ba9ac467ffa0c4564c7f6b1d3b2b3936f34fa73
diff --git a/app-arch/makeself/makeself-2.4.4.ebuild b/app-arch/makeself/makeself-2.4.4.ebuild
new file mode 100644
index 000000000000..55fe1ca89293
--- /dev/null
+++ b/app-arch/makeself/makeself-2.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NB: The test framework requires bashunit (which isn't a big deal), but the
+# tests themselves are not of great quality. You should avoid running them
+# yourself as they like to run commands like gpg against your own ~/ settings.
+
+EAPI="7"
+
+inherit optfeature
+
+DESCRIPTION="Shell script that generates a self-extractible tar.gz"
+HOMEPAGE="http://www.megastep.org/makeself/"
+SRC_URI="https://github.com/megastep/makeself/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_compile() { :; }
+
+src_install() {
+ dobin makeself-header.sh makeself.sh
+ dosym makeself.sh /usr/bin/makeself
+ doman makeself.1
+ dodoc README.md makeself.lsm
+}
+
+pkg_postinst() {
+ optfeature "lz4 support" app-arch/lz4
+ optfeature "lzop support" app-arch/lzop
+ optfeature "pbzip2 support" app-arch/pbzip2
+ optfeature "pigz support" app-arch/pigz
+ optfeature "zstd support" app-arch/zstd
+
+ # Also bzip2 and xz are supported but they are in @system.
+}