summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Miller <alex.miller@gmx.de>2023-12-22 01:28:57 +0100
committerSam James <sam@gentoo.org>2023-12-22 06:44:31 +0000
commit469d268abbf90f24770d3ad7ba332c82ccfe07f5 (patch)
treed4be680cb12ce08f32f617073ed703f8ca286f86 /app-arch
parentnet-p2p/amule: remove old (diff)
downloadgentoo-469d268abbf90f24770d3ad7ba332c82ccfe07f5.tar.gz
gentoo-469d268abbf90f24770d3ad7ba332c82ccfe07f5.tar.bz2
gentoo-469d268abbf90f24770d3ad7ba332c82ccfe07f5.zip
app-arch/torrentzip: Switch to new upstream and add 1.0
Bug: https://bugs.gentoo.org/920358 Signed-off-by: Alexander Miller <alex.miller@gmx.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/torrentzip/Manifest1
-rw-r--r--app-arch/torrentzip/torrentzip-1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-arch/torrentzip/Manifest b/app-arch/torrentzip/Manifest
index e33a18a286e3..61986c10ea85 100644
--- a/app-arch/torrentzip/Manifest
+++ b/app-arch/torrentzip/Manifest
@@ -1 +1,2 @@
DIST torrentzip-0.9.tar.gz 59007 BLAKE2B eb5d7d8d9026115367afd88ef0cf33d2eed600e6eaa773f039a713c76a48a39e12cb5a8ac6faf2937d3563c9270029543bdb6361d2f22a39e2341953872f589c SHA512 691cd25f501de3de16b5b15b2afadfc34b833c3e93208c2c3497674936580ad2c3532a02e02531b89974302eee7b36f7579a412718914b1b38044b78a39a4d4d
+DIST trrntzip-1.0.tar.gz 57643 BLAKE2B 45d4df51f26538b64c70f7310851954995f5d30dcae85b15e702c7518f6a2c4dbebf13ff2746028357dfc9f4c49fd095affb59b893746a4e6bf9b5f9dcd1814a SHA512 4624697528385cb85c9688dbfe56e039ca2d87e28dfdc9b299cb88fb2c7c34c664b58e473a7519ee4ecd89baea5f1369cd719c289e884ad19569d4c69d9a40ab
diff --git a/app-arch/torrentzip/torrentzip-1.0.ebuild b/app-arch/torrentzip/torrentzip-1.0.ebuild
new file mode 100644
index 000000000000..71f49e95d651
--- /dev/null
+++ b/app-arch/torrentzip/torrentzip-1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="trrntzip-${PV}"
+
+DESCRIPTION="Create identical zip archives over multiple systems"
+HOMEPAGE="https://github.com/0-wiz-0/trrntzip"
+SRC_URI="https://github.com/0-wiz-0/trrntzip/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=(AUTHORS NEWS.md README.md)
+
+src_configure() {
+ export CPPFLAGS+=' -DOF\\\(args\\\)=args'
+ cmake_src_configure
+}