summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2024-02-25 07:40:25 +0100
committerHanno Böck <hanno@gentoo.org>2024-02-25 07:40:32 +0100
commit474af25bcf735b3f823d08bb735e1fdd587908ae (patch)
tree045a319bf7d0b804de862ae60daf4e188eeb5317 /app-arch
parentkde-plasma/discover: add usedepdefault for snapd-glib (diff)
downloadgentoo-474af25bcf735b3f823d08bb735e1fdd587908ae.tar.gz
gentoo-474af25bcf735b3f823d08bb735e1fdd587908ae.tar.bz2
gentoo-474af25bcf735b3f823d08bb735e1fdd587908ae.zip
app-arch/unp: add 2.0
Re-enable tests (fixed upstream). Signed-off-by: Hanno Böck <hanno@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unp/Manifest1
-rw-r--r--app-arch/unp/unp-2.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/unp/Manifest b/app-arch/unp/Manifest
index 62ee15e4c8d4..1388f986cc78 100644
--- a/app-arch/unp/Manifest
+++ b/app-arch/unp/Manifest
@@ -1,2 +1,3 @@
+DIST unp_2.0.tar.xz 19252 BLAKE2B d807cdae6cccd846b3d138b7060b17f37f6f6962e2dd75400e86f0fd8f7f4721afbf29509dfce16beb5dac66996df45cc146d72312f859999f33d435f66890d5 SHA512 bdb2059aa3f1872efd49eb6c8e2fa3a09c05d9e1c26abdcfc4e728699c25a132ea610525461e94183263086756e9b60daeb5cecf69533578d01ab1a37b0af744
DIST unp_2.0~pre10.tar.xz 17992 BLAKE2B 63d8c995091a1342677b6aed5854293c582cb6d42c6748ef3d92347ca75e1d3e9e5b128309299ec0b6fc0361bc14dededcc8e290fe8721aecfe82665e07998e9 SHA512 3f8f9f20eef88658b4b00efd37208d859fb3220178f9446696f755a864fea3c3dd301100668bd9c97ca9312ebe961aaf9ec523d8817b8aacb5a1ee6a36213666
DIST unp_2.0~pre9.tar.xz 16424 BLAKE2B 9042f48be0f80d5e40a08161a35c282ba458dc98cf13992835bdeecebd5fbadd33b3af9165738332cb9f508550a234a48d314332f00ecdacc808a8051eb0740b SHA512 74c9a6e143c9023bdd456dacff5c3a6e30722e259f324c066fe3eed9e4a09c38b399b381719c8677c2fa84434c1e7720384d782d97c098fa6fbcbdbf4030986e
diff --git a/app-arch/unp/unp-2.0.ebuild b/app-arch/unp/unp-2.0.ebuild
new file mode 100644
index 000000000000..adda2e2d2d1b
--- /dev/null
+++ b/app-arch/unp/unp-2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 strip-linguas
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${PV}.tar.xz"
+S="${WORKDIR}/${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="nls test"
+
+DEPEND="nls? ( sys-devel/gettext )
+ test? ( app-arch/lzop
+ app-arch/lzip
+ app-arch/zstd )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ if use nls; then
+ strip-linguas -i .
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.po }.po"
+ else
+ emake -C po
+ fi
+ fi
+}
+
+src_install() {
+ dobin unp
+ dosym unp /usr/bin/ucat
+ doman debian/unp.1
+ dodoc debian/changelog debian/README.Debian
+ newbashcomp debian/unp.bash-completion unp
+
+ if use nls; then
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ else
+ emake -C po DESTDIR="${D}" install
+ fi
+ fi
+}