summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-05-24 15:15:18 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-05-24 15:15:33 +0200
commit4eef4f1444cb45ca61b14c11969f0aac4cd087ff (patch)
treeaca0101665a790ca9011c47ebfd8f12b466d9743 /app-arch
parentmedia-gfx/imagemagick: drop old (diff)
downloadgentoo-4eef4f1444cb45ca61b14c11969f0aac4cd087ff.tar.gz
gentoo-4eef4f1444cb45ca61b14c11969f0aac4cd087ff.tar.bz2
gentoo-4eef4f1444cb45ca61b14c11969f0aac4cd087ff.zip
app-arch/lbzip2: bump to snapshot release from 2018-12-27
Closes: https://bugs.gentoo.org/686660 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lbzip2/Manifest1
-rw-r--r--app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/lbzip2/Manifest b/app-arch/lbzip2/Manifest
index 1e28c06e66eb..8a96825a5a1b 100644
--- a/app-arch/lbzip2/Manifest
+++ b/app-arch/lbzip2/Manifest
@@ -1,2 +1,3 @@
DIST lbzip2-2.3.tar.gz 630226 BLAKE2B c08a7257eff859c0b7fb66ae638a57f837f1a2380c500c42ea65dc36e5650b30865d3c4c9820d6fed62bdbc4e3bdf7bae9e8bfe519897d9aac7f0c77cceacfb2 SHA512 4f694445cc90377bf8dac5046b952ff174db571f390c2d7b0aa001f73c76f3d3f048ff8e7297c2055ed1f7b210174496dc31d6628e1cbeff63146a36a442ad4c
DIST lbzip2-2.5.tar.gz 651399 BLAKE2B a53fc34084ed16c0e78a9f084f68fc0bd1217245e9470ee023f0a4f5a1e2ae4e5866086f9fbc3ff7ec5654c595b4388d9eff495bc0228edbe0322bf9d1fd1f23 SHA512 76e96cfa75b3ed515b2f891349dffc1403daab2dd0a2a614fa0c811cec6ca25faa395da08ad68a9b6ba4069332c4571f70fb7424f06ef3d800c3082c08d7d3d7
+DIST lbzip2-2.5_p20181227.tar.gz 704920 BLAKE2B e5da0091c0e4fb73724c5ea472d757d76356cffbf1fc679bf4ee05e25690b7712dceaf17f355383bfd4eb525c4aea04c2e5312592df5bb99159e000769bcee2e SHA512 53b29721a106d280927f2c18f33247645bb7fb3e67d835885d73e037910bf02e473f1210d848df41a387be30f829213d98ac9387b2a9201b94d12117809fbcf5
diff --git a/app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild b/app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild
new file mode 100644
index 000000000000..930340af6116
--- /dev/null
+++ b/app-arch/lbzip2/lbzip2-2.5_p20181227.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Parallel bzip2 utility"
+HOMEPAGE="https://github.com/kjn/lbzip2/"
+SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug symlink"
+
+RDEPEND="symlink? ( !app-arch/pbzip2[symlink] )"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3-s_isreg.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug tracing)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/bzip2
+ dosym lbunzip2 /usr/bin/bunzip2
+ fi
+}