summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-27 01:35:49 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-27 01:35:49 +0200
commit5847e32605457f4c68ac4f89bfaa28a9e6cfafd4 (patch)
tree98c6f6f3dd6732dc5df93c212a936f0b441e51f6 /app-arch
parentdev-vcs/git: sh stable (#697962) (diff)
downloadgentoo-5847e32605457f4c68ac4f89bfaa28a9e6cfafd4.tar.gz
gentoo-5847e32605457f4c68ac4f89bfaa28a9e6cfafd4.tar.bz2
gentoo-5847e32605457f4c68ac4f89bfaa28a9e6cfafd4.zip
app-arch/lrzip: bump to v0.631_p20190619
Bug: https://bugs.gentoo.org/624462 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lrzip/Manifest1
-rw-r--r--app-arch/lrzip/lrzip-0.631_p20190619.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-arch/lrzip/Manifest b/app-arch/lrzip/Manifest
index 3f86e8198ffb..90dbe892c213 100644
--- a/app-arch/lrzip/Manifest
+++ b/app-arch/lrzip/Manifest
@@ -1,2 +1,3 @@
DIST lrzip-0.621.tar.bz2 503286 BLAKE2B 3fb80f72f0bb81340d4e83b996ad2cd94fc0067b8e67599defb535e86614ad4a2436d8e6ab00bae24e4c9799a01aef267a7078cc6745d68acf868d0f1dbd606a SHA512 be94f54c3d84c93e3c1ab7b08ca6d2a02bc343983785be4884f42521520d2babc31db3abbec4b77dc9f710d18648adcc3d24b203289d8d4728afb3ef0fb90c0a
DIST lrzip-0.631.tar.bz2 522158 BLAKE2B d0ffe63e1bdd21304d6d7a7dc969d4e79770fed105cf03ea9d504f890cda35178566afa5f88e13beadcc1095f052a014deada3b3f102247eadb8c746d989d119 SHA512 6420cd465ccd4581066408482335a82089f84f0aca1b05249b9fc6039b7e67df94457a7c871859e363206df3a40e93cfde576388785113f6c99b31d34c00a307
+DIST lrzip-0.631_p20190619.tar.gz 259195 BLAKE2B d0bedfe02485011e48fa07240b1eef68560d8d61f5d28dae25bd9fcb1c41c1b8bc1b552acb06a49d853b70a0912371cec9caebb2bf7905ef528c2408d2153297 SHA512 f366c31c84a52f6ccfba56e8b11c0bcd270482d9d120e07783fbe310d7a62dddfa60ecd310a7630e7c98cfb961f57fc9e6b843d3857d0c90d36c580074528298
diff --git a/app-arch/lrzip/lrzip-0.631_p20190619.ebuild b/app-arch/lrzip/lrzip-0.631_p20190619.ebuild
new file mode 100644
index 000000000000..cb008dc298b4
--- /dev/null
+++ b/app-arch/lrzip/lrzip-0.631_p20190619.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_COMMIT="b9220181288c5c9920ff00f00005b31a9e40e387"
+
+DESCRIPTION="Long Range ZIP or Lzma RZIP optimized for compressing large files"
+HOMEPAGE="https://github.com/ckolivas/lrzip"
+SRC_URI="https://github.com/ckolivas/lrzip/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/lzo
+ app-arch/bzip2
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ x86? ( dev-lang/nasm )
+ virtual/perl-Pod-Parser"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-missing-stdarg_h.patch
+ "${FILESDIR}"/${PN}-0.631-solaris.patch
+)
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ # Don't collide with net-dialup/lrzsz and /usr/bin/lrz, bug #588206
+ rm -f "${ED}"/usr/bin/lrz
+ rm -f "${ED}"/usr/share/man/man1/lrz.*
+
+ find "${D}" -name '*.la' -delete || die
+}