summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-04-20 16:56:07 +0300
committerMart Raudsepp <leio@gentoo.org>2024-04-20 17:36:16 +0300
commit5d7103a6c8c22e51532b8fa30b6a192e813053e0 (patch)
tree0325c29f84ac93ef74300b9b459b2bce22dec990 /app-arch
parentx11-libs/pango: add 1.52.2 (diff)
downloadgentoo-5d7103a6c8c22e51532b8fa30b6a192e813053e0.tar.gz
gentoo-5d7103a6c8c22e51532b8fa30b6a192e813053e0.tar.bz2
gentoo-5d7103a6c8c22e51532b8fa30b6a192e813053e0.zip
app-arch/file-roller: add 44.1
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/file-roller/Manifest1
-rw-r--r--app-arch/file-roller/file-roller-44.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/app-arch/file-roller/Manifest b/app-arch/file-roller/Manifest
index a585b313b19c..52e6538bbc51 100644
--- a/app-arch/file-roller/Manifest
+++ b/app-arch/file-roller/Manifest
@@ -1 +1,2 @@
+DIST file-roller-44.1.tar.xz 927156 BLAKE2B 60ced1711298989eda90a675095b5e7b8f1e9b84b5f4cf364bce4683ba9eac6a8a4a1857b0248cd9a49ea2161cbc5c2c36df94ebc164e195de528ba50220d1da SHA512 de0d0ce93ecba822ec495227cd484cb164a81f8b5349033d80207acc19584985f0c88bfa766a46468349e2b16b020371e2e6b73b4fb7f2f18f40f115f2391b30
DIST file-roller-44.tar.xz 924236 BLAKE2B 12eebd312afdec8f87141d384d1476be7296073f911791328158af1ab93fcb4092ee79e0c65743c36eaa28e06b5b59503357b6c4cff87b4896d3969a67d08e45 SHA512 d40ac036161397828ded2bab7bdf1c029ef0b53fad65e0922e6eeec40442eb7a9898a7d5c3208f6dfda3ad6f51b0771f248ab64c177769b655493a44c403f824
diff --git a/app-arch/file-roller/file-roller-44.1.ebuild b/app-arch/file-roller/file-roller-44.1.ebuild
new file mode 100644
index 000000000000..6b9c0f7cfa2c
--- /dev/null
+++ b/app-arch/file-roller/file-roller-44.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/FileRoller"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="gtk-doc +introspection nautilus"
+REQUIRED_USE="gtk-doc? ( introspection )"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=gui-libs/gtk-4.8.1:4[introspection?]
+ >=gui-libs/libadwaita-1.2:1
+ nautilus? ( >=gnome-base/nautilus-43.0 )
+ >=dev-libs/json-glib-0.14
+ >=app-arch/libarchive-3.2:=
+ introspection? ( dev-libs/gobject-introspection )
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gi-docgen )
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+${PN} is a frontend for several archiving utilities. If you want a
+particular archive format support, see ${HOMEPAGE}
+and install the relevant package. For example:
+7-zip - app-arch/p7zip
+ace - app-arch/unace
+arj - app-arch/arj
+brotli - app-arch/brotli
+cpio - app-alternatives/cpio
+deb - app-arch/dpkg
+iso - app-cdr/cdrtools
+jar,zip - app-arch/zip and app-arch/unzip
+lha - app-arch/lha
+lzop - app-arch/lzop
+lz4 - app-arch/lz4
+rar - app-arch/unrar or app-arch/unar
+rpm - app-arch/rpm
+unstuff - app-arch/stuffit
+zstd - app-arch/zstd
+zoo - app-arch/zoo"
+
+src_prepare() {
+ # File providing Gentoo package names for various archivers
+ cp -v "${FILESDIR}"/3.36-packages.match data/packages.match || die
+
+ default
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Drun-in-place=false
+ $(meson_feature nautilus nautilus-actions)
+ -Dnotification=enabled
+ -Duse_native_appchooser=false
+ -Dpackagekit=false
+ -Dlibarchive=enabled
+ $(meson_feature introspection)
+ $(meson_feature gtk-doc api_docs)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/ || die
+ mv "${ED}"/usr/share/doc/file-roller "${ED}"/usr/share/gtk-doc/file-roller || die
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}