summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-05 16:48:46 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-05 16:49:14 -0400
commit6fa54e8cb856a425daa398868d99cb6a2ff3ff92 (patch)
tree7608f8d79dadf2dbe8c36aaa719bcb70589fef08 /app-arch
parentmail-client/evolution: Version bump to 3.44.4 (diff)
downloadgentoo-6fa54e8cb856a425daa398868d99cb6a2ff3ff92.tar.gz
gentoo-6fa54e8cb856a425daa398868d99cb6a2ff3ff92.tar.bz2
gentoo-6fa54e8cb856a425daa398868d99cb6a2ff3ff92.zip
app-arch/gcab: Version bump to 1.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gcab/Manifest1
-rw-r--r--app-arch/gcab/files/1.5-meson-git-version-is-optional.patch35
-rw-r--r--app-arch/gcab/gcab-1.5.ebuild56
3 files changed, 92 insertions, 0 deletions
diff --git a/app-arch/gcab/Manifest b/app-arch/gcab/Manifest
index 8922b04345a1..4aca7506d8f4 100644
--- a/app-arch/gcab/Manifest
+++ b/app-arch/gcab/Manifest
@@ -1 +1,2 @@
DIST gcab-1.4.tar.xz 78240 BLAKE2B 8b857c116fab636db93463cee7d6b809c3c7b2bdf3896b7b5b5b66ebf270b284b356710933ec17584143bcef5c1f5c555811dd05ea98399f327047476a33fc16 SHA512 66a2e0d0a5888c555153356ce808f602053e71b76af19794db7e3bbf9516fe791805068838b4e208698cd645ada7a08610ac95f846fa81e00a9b955016306299
+DIST gcab-1.5.tar.xz 81728 BLAKE2B ba1793a8374e2dac412ca2807343781013f5be8d79e444ef0a136fbf903dd9a47809b3dec4703ebd19d196a7046a0c8405ae8463c2f7338fdc5eaf979436e8e1 SHA512 2a9b7d2720abbb5527d478ac760898ae254d08b7aa929fbb21753296e5a07c51d62e134a3f8b1b21d9b557d4093505194e09823ddbaf58465d37b372f37534b7
diff --git a/app-arch/gcab/files/1.5-meson-git-version-is-optional.patch b/app-arch/gcab/files/1.5-meson-git-version-is-optional.patch
new file mode 100644
index 000000000000..6bfbaecf78a6
--- /dev/null
+++ b/app-arch/gcab/files/1.5-meson-git-version-is-optional.patch
@@ -0,0 +1,35 @@
+From ad0baea50359c1978a9224ee60bf98d97bfb991f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
+Date: Fri, 5 Aug 2022 11:13:41 +0400
+Subject: [PATCH] meson: git version is optional
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+My bad, git may be present, but running "git abbrev" from the tarball
+extracted project can fail.
+
+Fix commit a755e2ae77035aad9644adadaec5ecf15e9656ba ("meson: fix new
+warning about run_command()")
+
+Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 15fd5cd..5eba715 100644
+--- a/meson.build
++++ b/meson.build
+@@ -8,7 +8,7 @@ project('gcab', 'c',
+ git_version = []
+ git = find_program('git', required: false)
+ if git.found()
+- git_version = run_command(git, 'describe', '--abbrev=4', '--dirty', check: true).stdout().strip().split('-')
++ git_version = run_command(git, 'describe', '--abbrev=4', '--dirty', check: false).stdout().strip().split('-')
+ endif
+
+ # libtool versioning
+--
+2.35.1
+
diff --git a/app-arch/gcab/gcab-1.5.ebuild b/app-arch/gcab/gcab-1.5.ebuild
new file mode 100644
index 000000000000..acf17df81e42
--- /dev/null
+++ b/app-arch/gcab/gcab-1.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library and tool for working with Microsoft Cabinet (CAB) files"
+HOMEPAGE="https://wiki.gnome.org/msitools https://gitlab.gnome.org/GNOME/gcab"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.0:2
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-meson-git-version-is-optional.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection)
+ -Dnls=true
+ $(meson_use vala vapi)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}