summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-25 18:06:09 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-25 18:06:09 +0100
commit762b1eb93004fcc46674875d06401d7b068eaf04 (patch)
tree9b6785835813ae200d7756cb8c48c6ae8b2f5f88 /app-arch
parentmail-mta/postfix: add 3.9_pre20240124, drop 3.9_pre20240121 (diff)
downloadgentoo-762b1eb93004fcc46674875d06401d7b068eaf04.tar.gz
gentoo-762b1eb93004fcc46674875d06401d7b068eaf04.tar.bz2
gentoo-762b1eb93004fcc46674875d06401d7b068eaf04.zip
app-arch/lunzip: Bump to 1.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lunzip/Manifest2
-rw-r--r--app-arch/lunzip/lunzip-1.14.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lunzip/Manifest b/app-arch/lunzip/Manifest
index 022bb8ea530b..42b71b6f1d27 100644
--- a/app-arch/lunzip/Manifest
+++ b/app-arch/lunzip/Manifest
@@ -1,2 +1,4 @@
DIST lunzip-1.13.tar.gz 66541 BLAKE2B 45b6a4ffaac6d9b8ddeeebe5e33609bf4e671ad7370570035bacf41ee8ad35f49e14f495dfba650de284fedca1a63ebafe7f67c18083b4add94caaf7709d8e2b SHA512 67f950883b7062d37601bc16d7d64c07f6c580afbf3c0f61394dd6fb5d41c27214484b1dea7aabd41db06d18162b95b5734674646c4fcc833268cabe8cba91bb
DIST lunzip-1.13.tar.gz.sig 72 BLAKE2B a0d852dbb5394c5fb3e287cf4111290e0c603414de5a00a2d6173821df2410e4d826554ba4e04b5e9b7df0fa247cd95335a1a227b7cf38d4c5a7f3cc436be6ef SHA512 b71a73e7ad3a25140343db92c0ccf6311d0a30c71675e01a36da4735d0e0523d12d32b6472409359345ad6c9e550dccd399442d98fde44593af42f516119b3fb
+DIST lunzip-1.14.tar.gz 69284 BLAKE2B 8ef63a5cfd0cf839889785845ec84b23451cb69b1e09c84526e000b82b73aaaa01b99407e87bde416ca2ab638d9f9688fcb37f77fd53e2a8e0875646a54d304c SHA512 2aa530c4ef7ebcfa345c8ac8701712e7f973ee4a92d34c33a03dd02a31d76507c919da373b64bc6b49b7868af8e4444d4b12bd71b8760e9b333c2a013ad95da1
+DIST lunzip-1.14.tar.gz.sig 72 BLAKE2B ab2ba6c265f197c322884898ae8ff5c8679ab8a1d2f71a2dfedcce9011e16fb723fd592b0edc3f48d540ad8d2578b799f28f9d609a7e26379e39e0cb7f908cc3 SHA512 38806848f904fb3700c908166a1ad2d601409fa13f1b0dc69372766b41a6f37ae0c5792964b8aae494320d47e603dc79f36b3fa7361ccf84b89835c14a6b7b11
diff --git a/app-arch/lunzip/lunzip-1.14.ebuild b/app-arch/lunzip/lunzip-1.14.ebuild
new file mode 100644
index 000000000000..17e43370864d
--- /dev/null
+++ b/app-arch/lunzip/lunzip-1.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/antoniodiazdiaz.asc
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="Decompressor for the lzip format, written in C"
+HOMEPAGE="https://www.nongnu.org/lzip/lunzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/lunzip/${P}.tar.gz"
+SRC_URI+=" verify-sig? ( https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz.sig )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-antoniodiazdiaz )"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CPPFLAGS="${CPPFLAGS}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}