summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-17 18:42:16 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-17 18:42:32 +0100
commit88c70806a1f5dc21c0de4e3051be9fb3ade7b5d1 (patch)
tree7e602774e3dade76ed4eba6cce01445ca174e787 /app-arch
parentapp-arch/tar: Bump to version 1.30 (diff)
downloadgentoo-88c70806a1f5dc21c0de4e3051be9fb3ade7b5d1.tar.gz
gentoo-88c70806a1f5dc21c0de4e3051be9fb3ade7b5d1.tar.bz2
gentoo-88c70806a1f5dc21c0de4e3051be9fb3ade7b5d1.zip
app-arch/tar: Removed old.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/tar/tar-1.29-r2.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-arch/tar/tar-1.29-r2.ebuild b/app-arch/tar/tar-1.29-r2.ebuild
deleted file mode 100644
index 722e7f9b5f0d..000000000000
--- a/app-arch/tar/tar-1.29-r2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="https://www.gnu.org/software/tar/"
-SRC_URI="mirror://gnu/tar/${P}.tar.bz2
- mirror://gnu-alpha/tar/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="acl elibc_glibc minimal nls selinux static userland_GNU xattr"
-
-RDEPEND="acl? ( virtual/acl )
- selinux? ( sys-libs/libselinux )"
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.10.35 )
- xattr? ( elibc_glibc? ( sys-apps/attr ) )"
-
-PATCHES=(
- "${FILESDIR}/${P}-extract-pathname-bypass-upstream.patch" #598334
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- epatch_user
-
- if ! use userland_GNU ; then
- sed -i \
- -e 's:/backup\.sh:/gbackup.sh:' \
- scripts/{backup,dump-remind,restore}.in \
- || die "sed non-GNU"
- fi
-}
-
-src_configure() {
- use static && append-ldflags -static
- FORCE_UNSAFE_CONFIGURE=1 \
- econf \
- --enable-backup-scripts \
- --bindir="${EPREFIX}"/bin \
- --libexecdir="${EPREFIX}"/usr/sbin \
- $(usex userland_GNU "" "--program-prefix=g") \
- $(use_with acl posix-acls) \
- $(use_enable nls) \
- $(use_with selinux) \
- $(use_with xattr xattrs)
-}
-
-src_install() {
- default
-
- local p=$(usex userland_GNU "" "g")
- if [[ -z ${p} ]] ; then
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt
- fi
-
- # autoconf looks for gtar before tar (in configure scripts), hence
- # in Prefix it is important that it is there, otherwise, a gtar from
- # the host system (FreeBSD, Solaris, Darwin) will be found instead
- # of the Prefix provided (GNU) tar
- if use prefix ; then
- dosym tar /bin/gtar
- fi
-
- mv "${ED}"/usr/sbin/${p}backup{,-tar} || die
- mv "${ED}"/usr/sbin/${p}restore{,-tar} || die
-
- if use minimal ; then
- find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
- -type f -a '!' '(' -name tar -o -name ${p}tar ')' \
- -delete || die
- fi
-}