summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Dobosz <gryf73@gmail.com>2021-04-26 15:32:37 +0200
committerSam James <sam@gentoo.org>2021-04-26 15:49:53 +0000
commitaae03c0fdc38634ec8804af63c685828b6e820bf (patch)
tree33be00eecbcad81f39c6a27866f9e1c42464f8b6 /app-arch
parentnet-analyzer/vnstat: fix sync with live (diff)
downloadgentoo-aae03c0fdc38634ec8804af63c685828b6e820bf.tar.gz
gentoo-aae03c0fdc38634ec8804af63c685828b6e820bf.tar.bz2
gentoo-aae03c0fdc38634ec8804af63c685828b6e820bf.zip
app-arch/xdms: fix build issues with GCC 10.
Patch origins from Debian. Signed-off-by: Roman Dobosz <gryf73@gmail.com> Bug: https://bugs.gentoo.org/721896 Closes: https://github.com/gentoo/gentoo/pull/20548 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch80
-rw-r--r--app-arch/xdms/xdms-1.3.2-r2.ebuild1
2 files changed, 81 insertions, 0 deletions
diff --git a/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch b/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch
new file mode 100644
index 000000000000..dad00addead3
--- /dev/null
+++ b/app-arch/xdms/files/xdms-1.3.2-fix-build-with-gcc-10.patch
@@ -0,0 +1,80 @@
+https://sources.debian.org/patches/xdms/1.3.2-7/0002-Fix-build-with-gcc-10.patch/
+
+From: Jeff Law <law@redhat.com>
+Date: Sat, 9 May 2020 15:16:39 +0200
+Subject: Fix build with gcc-10
+--- a/src/u_deep.c
++++ b/src/u_deep.c
+@@ -17,9 +17,9 @@
+ #include "getbits.h"
+
+
+-INLINE USHORT DecodeChar(void);
+-INLINE USHORT DecodePosition(void);
+-INLINE void update(USHORT c);
++static INLINE USHORT DecodeChar(void);
++static INLINE USHORT DecodePosition(void);
++static INLINE void update(USHORT c);
+ static void reconst(void);
+
+
+@@ -98,7 +98,7 @@ USHORT Unpack_DEEP(UCHAR *in, UCHAR *out, USHORT origsize){
+
+
+
+-INLINE USHORT DecodeChar(void){
++static INLINE USHORT DecodeChar(void){
+ USHORT c;
+
+ c = son[R];
+@@ -117,7 +117,7 @@ INLINE USHORT DecodeChar(void){
+
+
+
+-INLINE USHORT DecodePosition(void){
++static INLINE USHORT DecodePosition(void){
+ USHORT i, j, c;
+
+ i = GETBITS(8); DROPBITS(8);
+@@ -171,7 +171,7 @@ static void reconst(void){
+
+ /* increment frequency of given code by one, and update tree */
+
+-INLINE void update(USHORT c){
++static INLINE void update(USHORT c){
+ USHORT i, j, k, l;
+
+ if (freq[R] == MAX_FREQ) {
+diff --git a/src/u_heavy.c b/src/u_heavy.c
+index fff93d3..8557b71 100644
+--- a/src/u_heavy.c
++++ b/src/u_heavy.c
+@@ -30,8 +30,8 @@ USHORT heavy_text_loc;
+
+ static USHORT read_tree_c(void);
+ static USHORT read_tree_p(void);
+-INLINE USHORT decode_c(void);
+-INLINE USHORT decode_p(void);
++static INLINE USHORT decode_c(void);
++static INLINE USHORT decode_p(void);
+
+
+
+@@ -74,7 +74,7 @@ USHORT Unpack_HEAVY(UCHAR *in, UCHAR *out, UCHAR flags, USHORT origsize){
+
+
+
+-INLINE USHORT decode_c(void){
++static INLINE USHORT decode_c(void){
+ USHORT i, j, m;
+
+ j = c_table[GETBITS(12)];
+@@ -96,7 +96,7 @@ INLINE USHORT decode_c(void){
+
+
+
+-INLINE USHORT decode_p(void){
++static INLINE USHORT decode_p(void){
+ USHORT i, j, m;
+
+ j = pt_table[GETBITS(8)];
diff --git a/app-arch/xdms/xdms-1.3.2-r2.ebuild b/app-arch/xdms/xdms-1.3.2-r2.ebuild
index a1bc96f7f59f..07dce668c10a 100644
--- a/app-arch/xdms/xdms-1.3.2-r2.ebuild
+++ b/app-arch/xdms/xdms-1.3.2-r2.ebuild
@@ -16,6 +16,7 @@ KEYWORDS="amd64 ~hppa ppc x86"
PATCHES=(
"${FILESDIR}"/${PN}-1.3.2-respect-DESTDIR.patch
"${FILESDIR}"/${PN}-1.3.2-dont-compress-man-pages.patch
+ "${FILESDIR}"/${PN}-1.3.2-fix-build-with-gcc-10.patch
)
src_prepare() {