summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-17 02:36:57 +0100
committerSam James <sam@gentoo.org>2021-04-18 02:38:17 +0100
commitbbfac96eed0ebaef8b9554271cdaf3f905d9c96a (patch)
tree47b0062c2aca3d16e41adb7a60835811b82a2512 /app-arch
parentapp-shells/squirrelsh: use BDEPEND for virtual/pkgconfig (diff)
downloadgentoo-bbfac96eed0ebaef8b9554271cdaf3f905d9c96a.tar.gz
gentoo-bbfac96eed0ebaef8b9554271cdaf3f905d9c96a.tar.bz2
gentoo-bbfac96eed0ebaef8b9554271cdaf3f905d9c96a.zip
app-arch/cksfv: bump to 1.3.15 (with DESTDIR fix)
Noticed there was a release after 11 years(!) so bumped while there for the VariableScope issue. Now respects ${DESTDIR}. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/cksfv/Manifest1
-rw-r--r--app-arch/cksfv/cksfv-1.3.15.ebuild27
-rw-r--r--app-arch/cksfv/files/cksfv-1.3.15-destdir.patch18
3 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/cksfv/Manifest b/app-arch/cksfv/Manifest
index 516489a30ace..d3a6b50f4253 100644
--- a/app-arch/cksfv/Manifest
+++ b/app-arch/cksfv/Manifest
@@ -1 +1,2 @@
DIST cksfv-1.3.14.tar.bz2 26114 BLAKE2B 696ae3499bc2b1c566a40da202b70d30777ee07a7923ac567345872098626c82820a9bb75b711915e2274a3e0f1d7804ba58f8ce41dcca375391d778ba135a02 SHA512 016c2f61632980678957fe4b5bc9ecb30360efd548ff09bfbb7a31cc6fc36f6fe7936d3d819fe468a6208c71f8b625662aa3ae0abd668435d7273e149d7e4519
+DIST cksfv-1.3.15.tar.bz2 27282 BLAKE2B c1df7bac982815915327753d8f6b888cc53395a0066bc5b34fb310d540c50c3006be2b9f31ebfac269d961126b0046a5b63fbbbe9c05c265953b2d2a94602a7a SHA512 a0b5286e0dce610e8b482a55cf8af38f8f8256e175435b6f2518c6566ea844c3cf2981f96c7600c7eb9b23b35cf19f1b55f540ba0f73f1267e4593e744858d43
diff --git a/app-arch/cksfv/cksfv-1.3.15.ebuild b/app-arch/cksfv/cksfv-1.3.15.ebuild
new file mode 100644
index 000000000000..f6c62153bb39
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.15-destdir.patch
+)
+
+src_configure() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
+}
diff --git a/app-arch/cksfv/files/cksfv-1.3.15-destdir.patch b/app-arch/cksfv/files/cksfv-1.3.15-destdir.patch
new file mode 100644
index 000000000000..c9ae19b442d3
--- /dev/null
+++ b/app-arch/cksfv/files/cksfv-1.3.15-destdir.patch
@@ -0,0 +1,18 @@
+The build system doesn't know about DESTDIR which is a problem for us
+when we want to have isolation in our phases (src_configure shouldn't
+need to know ${ED}).
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -23,9 +23,9 @@ all:
+ cd src && $(MAKE)
+
+ install: all
+- mkdir -p "$(BINDIR)" "$(MANDIR)/man1/"
+- install src/cksfv "$(BINDIR)"
+- install -m 644 cksfv.1 "$(MANDIR)/man1/"
++ mkdir -p "$(DESTDIR)$(BINDIR)" "$(DESTDIR)$(MANDIR)/man1/"
++ install src/cksfv "$(DESTDIR)$(BINDIR)"
++ install -m 644 cksfv.1 "$(DESTDIR)$(MANDIR)/man1/"
+
+ clean:
+ rm -f *.o *~ *.core core