summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-11-02 18:25:37 +0100
committerFabian Groffen <grobian@gentoo.org>2019-11-02 18:26:11 +0100
commitc41e4e8d39a9d4399ffcabf91c1bcb9a9cc4607d (patch)
treec75e1a66b06807fa9f8dc3fa9afb96266e048ff6 /app-arch
parentgames-misc/bsd-games: update HOMEPAGE, SRC_URI, metadata (diff)
downloadgentoo-c41e4e8d39a9d4399ffcabf91c1bcb9a9cc4607d.tar.gz
gentoo-c41e4e8d39a9d4399ffcabf91c1bcb9a9cc4607d.tar.bz2
gentoo-c41e4e8d39a9d4399ffcabf91c1bcb9a9cc4607d.zip
app-arch/xar: version bump -r3 (417.1), bug #694606
Closes: https://bugs.gentoo.org/694606 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xar/Manifest1
-rw-r--r--app-arch/xar/xar-1.8-r3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/xar/Manifest b/app-arch/xar/Manifest
index 4205e8ead62b..ca6f1ec9cfae 100644
--- a/app-arch/xar/Manifest
+++ b/app-arch/xar/Manifest
@@ -1 +1,2 @@
DIST xar-400.tar.gz 213319 BLAKE2B 55b8695313a1a5ae778b62791f716af00edba7e7b01500eac4b951e04cf7b18e84e0d508ac5471996796e5ab59e4628a4f85a63a5929b372555e28b222c77ab1 SHA512 c54850d5443c776f18d788bf7d026b3b08274ee71321d1615238c9fa2d20cc0b21f3f298364b0d0eecd98ce2a6efc8d5039cabd5a21c2419c430d90db004d159
+DIST xar-417.1.tar.gz 219350 BLAKE2B 2ca073e52b8d7a12c3d33fb65ccaf0984b912f42e4e9dc52bcaec7af41bafcc530cd055da16646113fb24ee046122425a66351f88279ef79a0f0b2b04ae51f9a SHA512 4c3c61f5289d0b2e380cbde772b383da369ca8ad046f5d779e02f59300288c90c5e31d105a2c01ac17dc719b8b46b55d8d36a8b3b20360f315766fce92dec762
diff --git a/app-arch/xar/xar-1.8-r3.ebuild b/app-arch/xar/xar-1.8-r3.ebuild
new file mode 100644
index 000000000000..18ab6a29a1f7
--- /dev/null
+++ b/app-arch/xar/xar-1.8-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic multilib-minimal multilib ltprune
+
+APPLE_PV=417.1
+DESCRIPTION="An easily extensible archive format"
+HOMEPAGE="https://opensource.apple.com/source/xar/"
+SRC_URI="https://opensource.apple.com/tarballs/xar/xar-${APPLE_PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl kernel_Darwin"
+
+DEPEND="
+ !kernel_Darwin? (
+ !kernel_SunOS? ( virtual/acl )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.1-ext2.patch
+ "${FILESDIR}"/${PN}-1.8-safe_dirname.patch
+ "${FILESDIR}"/${PN}-1.8-arm-ppc.patch
+ "${FILESDIR}"/${PN}-1.8-openssl-1.1.patch
+)
+
+S=${WORKDIR}/${PN}-${APPLE_PV}/${PN}
+
+src_prepare() {
+ default
+
+ # make lib headers available (without installing first?)
+ cd "${S}"/include || die
+ mv ../lib/*.h . || die
+
+ # strip RPATH pointing to ED
+ cd "${S}"/src || die
+ sed -i -e 's/@RPATH@//' Makefile.inc.in || die
+}
+
+multilib_src_configure() {
+ use kernel_Darwin || append-libs $(pkg-config --libs openssl)
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-static
+ # botched check, fix it up
+ if use kernel_SunOS ; then
+ sed -i -e '/HAVE_SYS_ACL_H/s:^\(.*\)$:/* \1 */:' include/config.h || die
+ fi
+}
+
+multilib_src_install() {
+ default
+ prune_libtool_files
+}