summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-01-17 09:23:09 +0200
committerSam James <sam@gentoo.org>2024-01-30 11:32:23 +0000
commitc78a993ffb8ae66d1760a2843603894d52a1ba4a (patch)
tree4b07f4a45afeb9230080b8941f05e6b274523c67 /app-arch
parenteclass: update texlive eclasses for texlive 2023 (diff)
downloadgentoo-c78a993ffb8ae66d1760a2843603894d52a1ba4a.tar.gz
gentoo-c78a993ffb8ae66d1760a2843603894d52a1ba4a.tar.bz2
gentoo-c78a993ffb8ae66d1760a2843603894d52a1ba4a.zip
app-arch/patool: add 2.1.1
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/patool/Manifest1
-rw-r--r--app-arch/patool/patool-2.1.1.ebuild128
2 files changed, 129 insertions, 0 deletions
diff --git a/app-arch/patool/Manifest b/app-arch/patool/Manifest
index 40ce9a5d2c50..f611c509df74 100644
--- a/app-arch/patool/Manifest
+++ b/app-arch/patool/Manifest
@@ -2,3 +2,4 @@ DIST patool-1.12_p20230424.gh.tar.gz 1990425 BLAKE2B dd0ae58fd26ef1849c26cb68183
DIST patool-1.14.1.tar.gz 1992559 BLAKE2B 3468c6b7779806ecb906830043964f2fa88384569af4cad857d8519568a7670a403ce17ca5b495fae6ad129f109bfac38693bfe651bad54dc5e6a46b5b58ea4f SHA512 df5ce0f5275fcc0b653775b9fbc36e11dfff1fcf30e5caf78bbebbf2c169125c7d27e71481c7ba108d39fb12cebdf3d84ab8c40f1a5f061dea5e5304e2306481
DIST patool-1.15.0.tar.gz 1993753 BLAKE2B 18dbbb6d73862778af9774b64f192e20d48f1454c078a2ab0bf9ccf12f3de988b7799c5e6116b1f49fe48b2512968789d363e37aa504d622a72c22a620398f5f SHA512 c7cbcd829a803025a99df67c8d4aca1d803d3bd8e06f2897c65bc0e2475fbd42e273654f978090fe4c2bbcac02e5d1f8e322cb90220e746ac9ef9d0755e0c717
DIST patool-2.0.0.tar.gz 1987911 BLAKE2B a9c12f8083e82835792445f50e1e72f55e98c505f0019656cd00c1f882a860ae61c7484ea16c7744101b6a983c1934fad12dbb58af2a03e82d0ec4ceb417aa92 SHA512 c81a65fa89ff77ee80ae85fbc6868e5414d5141e47433028546273b3a231ce3240d6b30baae114247bc0ab0b3e4e91c6e127b8734eff9af8721abdae7f464ef5
+DIST patool-2.1.1.tar.gz 1991183 BLAKE2B f33c92c628ffcca349ad897c29cec935730aba7f2e9a5581acedb9b3ecb0bab22046cd16af9f2d2e605bc483c2dc624db01b52dea8459388a8b140b7f357b193 SHA512 3b51fe917da9672dbeae015852680b67e81ec35d609af3e465f0d53afb12c35bee885f4f3db4a135c01521cc70db182b27fc25320d141f96eaf098ba99524f63
diff --git a/app-arch/patool/patool-2.1.1.ebuild b/app-arch/patool/patool-2.1.1.ebuild
new file mode 100644
index 000000000000..b6b287767626
--- /dev/null
+++ b/app-arch/patool/patool-2.1.1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Portable archive file manager"
+HOMEPAGE="https://wummel.github.io/patool/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-arch/arj
+ app-arch/bzip2
+ app-arch/bzip3
+ app-arch/cabextract
+ app-alternatives/cpio
+ app-arch/dpkg
+ app-arch/gzip
+ app-arch/lbzip2
+ app-arch/lcab
+ app-arch/lha
+ app-arch/libarchive
+ app-arch/lz4
+ app-arch/lzip
+ app-arch/lzop
+ app-arch/ncompress
+ app-arch/p7zip[rar]
+ app-arch/pbzip2
+ app-arch/pdlzip
+ app-arch/pigz
+ app-arch/plzip
+ app-arch/rpm
+ app-arch/rzip
+ app-arch/sharutils
+ app-arch/tar
+ app-arch/unace
+ app-arch/unadf
+ app-arch/unzip
+ app-arch/xdms
+ app-arch/xz-utils
+ app-arch/zip
+ app-arch/zopfli
+ app-arch/zpaq
+ app-arch/zstd
+ app-cdr/cdrtools
+ dev-libs/chmlib
+ media-libs/flac
+ media-sound/shorten
+ sys-apps/diffutils
+ sys-apps/file
+ sys-apps/grep
+ !elibc_musl? ( app-arch/rar )
+ !x86? (
+ app-arch/clzip
+ app-arch/lrzip
+ app-arch/unar
+ )
+ )
+"
+# Test dependencies which are packaged but can't be tested for various reasons.
+# app-arch/arc
+# app-arch/zoo
+# media-sound/mac
+
+# app-arch/rar is masked on musl
+# app-arch/clzip is unkeyworded on x86
+# app-arch/lrzip bug #916317 on x86
+# app-arch/unar is unkeyworded on x86
+
+# Unpackaged testable dependencies
+# archmage
+# genisoimage
+# lhasa
+# nomarch
+# pdzip2
+# py_{bz2,echo,gzip,tarfile,zipfile}
+# rpm2cpio
+# rzip
+# star
+# unalz
+# uncompress.real
+# 7zz ( app-arch/7zip:guru )
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newdoc doc/README.txt README.md
+ doman doc/patool.1
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # zoo emits a non-zero exit status on a possibly false consistency check
+ # Zoo: WARNING: Archive header failed consistency check.
+ "tests/archives/test_zoo.py"
+ # Doesn't accept long arguments, such as those that files in ${S} would have.
+ # Too long argument: /var/tmp/portage/app-arch/patool-1.12_p20230424/work/patool-ab64562c8cdac34dfd69fcb6e30c8c0014282d11/tests/data/p.arc.foo
+ "tests/archives/test_arc.py"
+ # Error: 1002 (invalid input file)
+ "tests/archives/test_mac.py"
+ )
+
+ if use elibc_musl; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_rar.py"
+ )
+ fi
+
+ if use x86; then
+ EPYTEST_IGNORE+=(
+ "tests/archives/test_clzip.py"
+ # bug #916317
+ "tests/archives/test_lrzip.py::TestLrzip::test_lrzip"
+ )
+ fi
+
+ epytest
+}