summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-01 16:18:51 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-01 18:06:19 +0100
commitc915b78c5a4972a9bd0fdfad9f5dcdc1339a5293 (patch)
treeda3f65ddfb68b46bcc2e03e6a3f3fa56c8c8aa1b /app-arch
parentgnome-extra/gnome-calendar: cleanup old revisions (diff)
downloadgentoo-c915b78c5a4972a9bd0fdfad9f5dcdc1339a5293.tar.gz
gentoo-c915b78c5a4972a9bd0fdfad9f5dcdc1339a5293.tar.bz2
gentoo-c915b78c5a4972a9bd0fdfad9f5dcdc1339a5293.zip
app-arch/gnome-autoar: initial ebuild
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gnome-autoar/Manifest1
-rw-r--r--app-arch/gnome-autoar/gnome-autoar-0.1.1.ebuild34
-rw-r--r--app-arch/gnome-autoar/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/app-arch/gnome-autoar/Manifest b/app-arch/gnome-autoar/Manifest
new file mode 100644
index 000000000000..419006845f08
--- /dev/null
+++ b/app-arch/gnome-autoar/Manifest
@@ -0,0 +1 @@
+DIST gnome-autoar-0.1.1.tar.xz 292536 SHA256 f65cb810b562dc038ced739fbf59739fd5df1a8e848636e21f363ded9f349ac9 SHA512 59606cc7e3150d457b343f99bf30732bc9ea4bb7368133bba771a17d3253f23c8c60a35f4d686569fc2a9d4b4ab1e095b0f8cd7053493e1951e9d193a60c1e31 WHIRLPOOL 4cfc478c9956490cab5b48133585384e1282abf677290c94c93d59eba26ed4a5438d36622cfb73163d28a6692c990fb224782adbe9c9948814d3b83abb3ffcae
diff --git a/app-arch/gnome-autoar/gnome-autoar-0.1.1.ebuild b/app-arch/gnome-autoar/gnome-autoar-0.1.1.ebuild
new file mode 100644
index 000000000000..41b3a6600a71
--- /dev/null
+++ b/app-arch/gnome-autoar/gnome-autoar-0.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="Automatic archives creating and extracting library"
+HOMEPAGE="https://git.gnome.org/browse/gnome-autoar"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+IUSE="gtk +introspection"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-arch/libarchive-3.2.0
+ >=dev-libs/glib-2.35.6:2
+ gtk? ( >=x11-libs/gtk+-3.2:3 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable gtk)
+}
diff --git a/app-arch/gnome-autoar/metadata.xml b/app-arch/gnome-autoar/metadata.xml
new file mode 100644
index 000000000000..073497f97b3c
--- /dev/null
+++ b/app-arch/gnome-autoar/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+ gnome-autoar provides functions, widgets, and gschemas for GNOME applications which want to use archives as a method to transfer directories over the Internet.
+ </longdescription>
+</pkgmetadata>