summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-17 16:11:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-17 17:22:53 +0100
commitd16f43903d77cd3b91d42ab6516c4256f75ddf3e (patch)
tree694f39a6076a118bfd25b86ab8df87810873675b /app-arch
parentsys-apps/pciutils: Removes old. (diff)
downloadgentoo-d16f43903d77cd3b91d42ab6516c4256f75ddf3e.tar.gz
gentoo-d16f43903d77cd3b91d42ab6516c4256f75ddf3e.tar.bz2
gentoo-d16f43903d77cd3b91d42ab6516c4256f75ddf3e.zip
app-arch/bzip2: Removed old.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r6.ebuild113
1 files changed, 0 insertions, 113 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.6-r6.ebuild b/app-arch/bzip2/bzip2-1.0.6-r6.ebuild
deleted file mode 100644
index d7b2cdff3b07..000000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r6.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI=4
-
-inherit eutils toolchain-funcs multilib multilib-minimal
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="static static-libs"
-
-RDEPEND="abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20130224
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.6-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- epatch "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
- epatch "${FILESDIR}"/${PN}-1.0.6-out-of-tree-build.patch
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s -f :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- VPATH="${S}" \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@"
-}
-
-multilib_src_compile() {
- bemake -f "${S}"/Makefile-libbz2_so all
- bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
-}
-
-multilib_src_install() {
- into /usr
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV}
- local v
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v}
- done
- use static-libs && dolib.a libbz2.a
-
- if multilib_is_native_abi ; then
- gen_usr_ldscript -a bz2
-
- dobin bzip2recover
- into /
- dobin bzip2
- fi
-}
-
-multilib_src_install_all() {
- # `make install` doesn't cope with out-of-tree builds, nor with
- # installing just non-binaries, so handle things ourselves.
- insinto /usr/include
- doins bzlib.h
- into /usr
- dobin bz{diff,grep,more}
- doman *.1
-
- dosym bzdiff /usr/bin/bzcmp
- dosym bzdiff.1 /usr/share/man/man1/bzcmp.1
-
- dosym bzmore /usr/bin/bzless
- dosym bzmore.1 /usr/share/man/man1/bzless.1
-
- local x
- for x in bunzip2 bzcat bzip2recover ; do
- dosym bzip2.1 /usr/share/man/man1/${x}.1
- done
- for x in bz{e,f}grep ; do
- dosym bzgrep /usr/bin/${x}
- dosym bzgrep.1 /usr/share/man/man1/${x}.1
- done
-
- dodoc README* CHANGES manual.pdf
- dohtml manual.html
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}