summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-29 09:20:06 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-29 09:20:15 +0100
commitdc66baee3f174784ca7abe23580056f20cb52732 (patch)
treef63d66ee2f425e4df31edf08387f67974947a699 /app-arch
parentsci-libs/scipy: Add live ebuild for testing (diff)
downloadgentoo-dc66baee3f174784ca7abe23580056f20cb52732.tar.gz
gentoo-dc66baee3f174784ca7abe23580056f20cb52732.tar.bz2
gentoo-dc66baee3f174784ca7abe23580056f20cb52732.zip
app-arch/p7zip: Fix build problems for GUI
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564332 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/p7zip/p7zip-15.09.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-arch/p7zip/p7zip-15.09.ebuild b/app-arch/p7zip/p7zip-15.09.ebuild
index 048f4ccf81d8..2b4b810a842b 100644
--- a/app-arch/p7zip/p7zip-15.09.ebuild
+++ b/app-arch/p7zip/p7zip-15.09.ebuild
@@ -40,9 +40,6 @@ src_prepare() {
sed \
-e 's:-m32 ::g' \
-e 's:-m64 ::g' \
- -e 's:-O::g' \
- -e 's: -s ::g' \
- -e 's: -s$::g' \
-e 's:-pipe::g' \
-e "/^CXX=/s:g++:$(tc-getCXX):" \
-e "/^CC=/s:gcc:$(tc-getCC):" \
@@ -100,7 +97,7 @@ src_compile() {
emake all3
if use kde || use wxwidgets; then
emake -- 7zG
- emake -- 7zFM
+# emake -- 7zFM
fi
}
@@ -116,13 +113,14 @@ src_install() {
if use kde || use wxwidgets; then
make_wrapper 7zG "/usr/$(get_libdir)/${PN}/7zG"
- make_wrapper 7zFM "/usr/$(get_libdir)/${PN}/7zFM"
+# make_wrapper 7zFM "/usr/$(get_libdir)/${PN}/7zFM"
- make_desktop_entry 7zFM "${PN} FM" ${PN} "GTK;Utility;Archiving;Compression"
+# make_desktop_entry 7zFM "${PN} FM" ${PN} "GTK;Utility;Archiving;Compression"
dobin GUI/p7zipForFilemanager
exeinto /usr/$(get_libdir)/${PN}
- doexe bin/7z{G,FM}
+# doexe bin/7z{G,FM}
+ doexe bin/7zG
insinto /usr/$(get_libdir)/${PN}
doins -r GUI/{Lang,help}