summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2024-02-22 16:17:04 +0000
committerJimi Huotari <chiitoo@gentoo.org>2024-02-23 19:03:02 +0200
commitdcfa15126042f73aa9a9f5f8fba877284a67fded (patch)
tree81a6ffec814fd4e9cc794719f04e18d120423663 /app-arch
parentnet-libs/nodejs: Apply 20.11.0 riscv patch to 20.11.1 (diff)
downloadgentoo-dcfa15126042f73aa9a9f5f8fba877284a67fded.tar.gz
gentoo-dcfa15126042f73aa9a9f5f8fba877284a67fded.tar.bz2
gentoo-dcfa15126042f73aa9a9f5f8fba877284a67fded.zip
app-arch/lxqt-archiver: add 0.9.1
Closes: https://github.com/gentoo/gentoo/pull/35488 Signed-off-by: Michael Vetter <jubalh@iodoru.org> Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lxqt-archiver/Manifest1
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-0.9.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index 8ce1a6460ee6..0e47e0664cb1 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-archiver-0.8.0.tar.xz 181572 BLAKE2B 7bbd2b229cd8c546c86d742c13dac4bd00e24e85a146879290652a9ae41c9ced621738d06284fe285c81f2d5f8e43a5126b9bc61e286342cfb9d7fa935c330ee SHA512 70266581478e75505f708eccee4fd1680c1ff012dd4e99138d0c2d17fb8dfab24d9d5e5453d5d4a3f7a9b8437e8a980c3edf190f3e319400c46a655ba7db4898
DIST lxqt-archiver-0.9.0.tar.xz 183352 BLAKE2B 60443b7f4407b85bc1233f00ad2e46861c17281331d3b611021ca14be2e159befa0c8303d51b9021d35aa246d4fd9138ceb4f4b19cd6143438f8c3b976f9c40d SHA512 42ee097ae7fb17dbd00d9b94e8673664911c73bb5f353d08177c78d548eb24c39aa1daf57347eeefcb46ec63a8702c37f63ca2b42fd22bc85aed8f7a41585f3c
+DIST lxqt-archiver-0.9.1.tar.xz 186600 BLAKE2B 365b849578f9f663ed7628c52c4c7205af10ea255dd131a94a6960c581111e02fedee01be0bd674d1ef71c9648cc5a58de1b548c972eb415cfae990e7045cfb4 SHA512 fd7862c85f6f93c870a4b28d2ed3705fcc0431e9b4d887f4fab6d860eddc5fe99d8a4c2f7cd2957c34d72b74a11b8eec49bbcca40dfee11f20f6a39f37e9ee00
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-0.9.1.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-0.9.1.ebuild
new file mode 100644
index 000000000000..c5fe417b24b6
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-0.9.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~loong ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.13.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=x11-libs/libfm-qt-1.4:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}