summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-19 20:38:42 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-19 21:13:51 +0100
commite40c197fe23c600321f6310df333ed19df74cf88 (patch)
treebdc2d6a3e6e02fca5aaa40d3128b17f1124fd56f /app-arch
parentnet-misc/wget: Removed old. (diff)
downloadgentoo-e40c197fe23c600321f6310df333ed19df74cf88.tar.gz
gentoo-e40c197fe23c600321f6310df333ed19df74cf88.tar.bz2
gentoo-e40c197fe23c600321f6310df333ed19df74cf88.zip
app-arch/xar: Enable multilib support (needed for LLVM)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/xar/xar-1.8.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-arch/xar/xar-1.8.ebuild b/app-arch/xar/xar-1.8.ebuild
index d5fa86494a62..b9e8a69274a8 100644
--- a/app-arch/xar/xar-1.8.ebuild
+++ b/app-arch/xar/xar-1.8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit flag-o-matic ltprune
+inherit flag-o-matic multilib-minimal ltprune
APPLE_PV=400
DESCRIPTION="An easily extensible archive format"
@@ -16,12 +16,12 @@ IUSE="libressl kernel_Darwin"
DEPEND="
!kernel_Darwin? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
)
- app-arch/bzip2
- sys-libs/zlib
- dev-libs/libxml2
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"
@@ -34,13 +34,14 @@ src_prepare() {
sed -i -e 's/safe_dirname/xar_safe_dirname/' lib/linuxattr.c || die
}
-src_configure() {
+multilib_src_configure() {
use kernel_Darwin || append-libs $(pkg-config --libs openssl)
+ ECONF_SOURCE=${S} \
econf \
--disable-static
}
-src_install() {
+multilib_src_install() {
default
prune_libtool_files
}