summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-07-21 18:28:34 +0200
committerHanno Böck <hanno@gentoo.org>2020-07-21 18:28:34 +0200
commitf10eed384f27d5745fb2c571fb74d40599d2cfc9 (patch)
tree9f187ba13a9ca72f0e57e283f7abb0eb6118716c /app-arch
parentdev-db/phppgadmin: version bump to 7.12.1 (diff)
downloadgentoo-f10eed384f27d5745fb2c571fb74d40599d2cfc9.tar.gz
gentoo-f10eed384f27d5745fb2c571fb74d40599d2cfc9.tar.bz2
gentoo-f10eed384f27d5745fb2c571fb74d40599d2cfc9.zip
app-arch/unp: Version bump
Remove obsolete patch and unneeded complex version handling. Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.0, Repoman-2.3.23
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unp/Manifest1
-rw-r--r--app-arch/unp/unp-2.0_pre8.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-arch/unp/Manifest b/app-arch/unp/Manifest
index 7f7b15c166cc..eb5c120e901f 100644
--- a/app-arch/unp/Manifest
+++ b/app-arch/unp/Manifest
@@ -1 +1,2 @@
DIST unp_2.0~pre7+nmu1.tar.bz2 17537 BLAKE2B 7ef6cfcc524daf95c7cd9dc41ba690cb8db1b1983cd45709c8764591af36d6d00631975bfef0359ac633aae1c11b73efe827e367931f73fe7c5fcc8832b0fe84 SHA512 1b30f14c8d17e0a6b149ca4795f2219e9180f814347410e7ff7fa2b9720a9d308190f2ded8fcfd11bac9b5bb7a64ffd93f140bdaffcba1127f0e15e3d2737362
+DIST unp_2.0~pre8.tar.xz 16336 BLAKE2B 6c6ffd75acda980e6c572c48944b238788a64d2bf1f854b45a3bc468da19fc6e593a8b604d99dac51b5b645ec88b27300be6af4d988a56470812a7ae92f19336 SHA512 58d2a6a9f7fe868773273532b46249109e1e757517dd46e485f2b3a77fea404aeea34edf4460e76376806ae0d28baefa55f1063919bdf1493617f1b361fe6039
diff --git a/app-arch/unp/unp-2.0_pre8.ebuild b/app-arch/unp/unp-2.0_pre8.ebuild
new file mode 100644
index 000000000000..8116fc04c3ae
--- /dev/null
+++ b/app-arch/unp/unp-2.0_pre8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Script for unpacking various file formats"
+HOMEPAGE="https://packages.qa.debian.org/u/unp.html"
+MY_PV="${PV/_pre/$'\x7e'pre}"
+SRC_URI="mirror://debian/pool/main/u/unp/${PN}_${MY_PV}.tar.xz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ if use nls; then
+ strip-linguas -i .
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.po }.po"
+ else
+ emake -C po
+ fi
+ fi
+}
+
+src_install() {
+ dobin unp
+ dosym unp /usr/bin/ucat
+ doman debian/unp.1
+ dodoc debian/changelog debian/README.Debian
+ newbashcomp debian/unp.bash-completion unp
+
+ if use nls; then
+ if [ -n "$LINGUAS" ]; then
+ emake -C po MOFILES="${LINGUAS// /.mo }.mo" DESTDIR="${D}" install
+ else
+ emake -C po DESTDIR="${D}" install
+ fi
+ fi
+}