summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 21:58:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 08:55:10 +0100
commit2d8b2bb2ee60846487964164b5fcda3ef4a49b09 (patch)
tree5d603c648117c25a6f8d53069b650bc324766400 /app-backup/backintime
parentx11-misc/kdocker: delete old (diff)
downloadgentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.tar.gz
gentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.tar.bz2
gentoo-2d8b2bb2ee60846487964164b5fcda3ef4a49b09.zip
app-backup/backintime: EAPI-7, xdg, fix QA, add missing PyQt5 RDEPENDs
Drop cd Drop LINGUAS hack Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/backintime-9999.ebuild87
-rw-r--r--app-backup/backintime/files/backintime-1.2.1-no-compress-docs-examples.patch142
2 files changed, 178 insertions, 51 deletions
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 91c3e3acf41b..fc293b01096b 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -1,87 +1,72 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{6,7} )
-inherit python-single-r1 gnome2-utils git-r3
+inherit python-single-r1 git-r3 xdg
DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
-HOMEPAGE="https://backintime.readthedocs.io/ https://github.com/bit-team/backintime/"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
EGIT_REPO_URI="https://github.com/bit-team/backintime/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="qt5"
+IUSE="examples qt5"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
net-misc/openssh
- net-misc/rsync[xattr,acl]"
+ net-misc/rsync[xattr,acl]
+"
RDEPEND="${DEPEND}
- qt5? ( dev-python/PyQt5 )"
+ qt5? ( dev-python/PyQt5[gui,widgets] )
+"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_prepare() {
- #fix doc install location
- sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
- -i common/configure || die
- sed -e "s:/doc/${PN}-qt:/doc/${PF}:g" \
- -i qt/configure || die
- sed -e "/addInstallFile \"..\/VERSION/d" \
- -e "/addInstallFile \"..\/LICENSE/d" \
- -e "/addInstallFile \"..\/debian\/copyright/d" \
- -i {qt,common}/configure || die
-
- if [ -n ${LINGUAS+x} ] ; then
- cd common/po || die
- for po in *.po ; do
- if ! has ${po/.po} ${LINGUAS} ; then
- rm ${po} || die
- fi
- done
- fi
-
- default
-}
+PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
src_configure() {
- cd "${S}"/common || die
- ./configure --python3 --no-fuse-group || die
+ pushd common > /dev/null || die
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
if use qt5 ; then
- cd "${S}"/qt || die
- ./configure --python3 || die
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
fi
}
src_compile() {
- cd "${S}"/common || die
- emake
- if use qt5 ; then
- cd "${S}"/qt || die
+ pushd common > /dev/null || die
emake
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake
+ popd > /dev/null || die
fi
}
src_install() {
- cd "${S}"/common || die
- emake DESTDIR="${D}" install
- if use qt5 ; then
- cd "${S}"/qt || die
+ pushd common > /dev/null || die
emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
fi
- python_optimize "${D}"
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
+ einstalldocs
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
-pkg_postrm() {
- gnome2_icon_cache_update
+ python_optimize "${D}"
}
diff --git a/app-backup/backintime/files/backintime-1.2.1-no-compress-docs-examples.patch b/app-backup/backintime/files/backintime-1.2.1-no-compress-docs-examples.patch
new file mode 100644
index 000000000000..4a2fd840fda9
--- /dev/null
+++ b/app-backup/backintime/files/backintime-1.2.1-no-compress-docs-examples.patch
@@ -0,0 +1,142 @@
+From 897f81aefa1dfcfb8c645375e0c4baeadd39c9c0 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Tue, 31 Dec 2019 22:13:23 +0100
+Subject: [PATCH] No compress, no DOCS install, no examples install, fix
+ docbook path
+
+---
+ common/configure | 36 ++++--------------------------------
+ qt/configure | 30 ++++++------------------------
+ 2 files changed, 10 insertions(+), 56 deletions(-)
+
+diff --git a/common/configure b/common/configure
+index 87cdc48..c1dd1af 100755
+--- a/common/configure
++++ b/common/configure
+@@ -166,7 +166,7 @@ printf "DEST=\$(DESTDIR)\$(PREFIX)\n\n" >> ${MAKEFILE}
+
+ printf "all:\tbuild\n\n" >> ${MAKEFILE}
+
+-printf "build:\ttranslate compress\n\n" >> ${MAKEFILE}
++printf "build:\ttranslate\n\n" >> ${MAKEFILE}
+
+ printf "clean:\n" >> ${MAKEFILE}
+ printf "\trm -f po/*.mo\n" >> ${MAKEFILE}
+@@ -191,30 +191,11 @@ addInstallFiles "plugins/*.py" "/share/backintime/plugins"
+ addUninstallDir "/share/backintime"
+ addNewline
+
+-addComment "documentation"
+-addInstallDir "/share/doc/backintime-common"
+-addInstallFile "../debian/copyright" "/share/doc/backintime-common"
+-addInstallFile "../AUTHORS" "/share/doc/backintime-common"
+-addInstallFile "../LICENSE" "/share/doc/backintime-common"
+-addInstallFile "../README.md" "/share/doc/backintime-common"
+-addInstallFile "../TRANSLATIONS" "/share/doc/backintime-common"
+-addInstallFile "../VERSION" "/share/doc/backintime-common"
+-addInstallFile "../CHANGES" "/share/doc/backintime-common"
+-addNewline
+-
+-addComment "config-examples"
+-addInstallDir "/share/doc/backintime-common/examples"
+-addInstallFile "config-example-local.gz" "/share/doc/backintime-common/examples"
+-addInstallFile "config-example-ssh.gz" "/share/doc/backintime-common/examples"
+-addUninstallDir "/share/doc/backintime-common"
+-addUninstallDir "/share/doc"
+-addNewline
+-
+ addComment "man"
+ addInstallDir "/share/man/man1"
+-addInstallFile "man/C/backintime.1.gz" "/share/man/man1"
+-addInstallFile "man/C/backintime-askpass.1.gz" "/share/man/man1"
+-addInstallFile "man/C/backintime-config.1.gz" "/share/man/man1"
++addInstallFile "man/C/backintime.1" "/share/man/man1"
++addInstallFile "man/C/backintime-askpass.1" "/share/man/man1"
++addInstallFile "man/C/backintime-config.1" "/share/man/man1"
+ addUninstallDir "/share/man"
+ addNewline
+
+@@ -238,15 +219,6 @@ addSymlink "backintime" "/share/bash-completion/completions/backinti
+ addUninstallDir "/share/bash-completion"
+ addNewline
+
+-#compress
+-printf "compress:\n" >> ${MAKEFILE}
+-printf "\t#man pages\n" >> ${MAKEFILE}
+-printf "\tfor i in \$\$(ls -1 man/C/); do case \$\$i in *.gz|*~) continue;; *) gzip -n --best -c man/C/\$\$i > man/C/\$\${i}.gz;; esac; done\n\n" >> ${MAKEFILE}
+-
+-printf "\t#config-examples\n" >> ${MAKEFILE}
+-printf "\tgzip -n --best -c config-example-local > config-example-local.gz\n" >> ${MAKEFILE}
+-printf "\tgzip -n --best -c config-example-ssh > config-example-ssh.gz\n\n" >> ${MAKEFILE}
+-
+ #translate
+ printf "translate:\t$mos\n\n" >> ${MAKEFILE}
+
+diff --git a/qt/configure b/qt/configure
+index 4b56b70..8bbdfcb 100755
+--- a/qt/configure
++++ b/qt/configure
+@@ -126,7 +126,7 @@ printf "DEST=\$(DESTDIR)\$(PREFIX)\n\n" >> ${MAKEFILE}
+
+ printf "all:\tbuild\n\n" >> ${MAKEFILE}
+
+-printf "build:\tcompress\n\n" >> ${MAKEFILE}
++printf "build:\t\n\n" >> ${MAKEFILE}
+
+ printf "clean:\n" >> ${MAKEFILE}
+ printf "\trm -f po/*.mo\n" >> ${MAKEFILE}
+@@ -174,34 +174,21 @@ addInstallFiles "net.launchpad.backintime*.policy" "/share/polkit-1/actions"
+ addUninstallDir "/share/polkit-1"
+ addNewline
+
+-addComment "documentation"
+-addInstallDir "/share/doc/backintime-qt"
+-addInstallFile "../debian/copyright" "/share/doc/backintime-qt"
+-addInstallFile "../AUTHORS" "/share/doc/backintime-qt"
+-addInstallFile "../LICENSE" "/share/doc/backintime-qt"
+-addInstallFile "../README.md" "/share/doc/backintime-qt"
+-addInstallFile "../TRANSLATIONS" "/share/doc/backintime-qt"
+-addInstallFile "../VERSION" "/share/doc/backintime-qt"
+-addInstallFile "../CHANGES" "/share/doc/backintime-qt"
+-addNewline
+-
+ addComment ".desktop"
+ addInstallDir "/share/applications"
+ addInstallFiles "*.desktop" "/share/applications"
+ addNewline
+
+ addComment "docbook"
+-addInstallDir "/share/doc/qt/HTML/en/backintime"
+-addInstallFiles "docbook/en/*.docbook" "/share/doc/qt/HTML/en/backintime"
+-addUninstallDir "/share/doc/qt/HTML/en"
+-addUninstallDir "/share/doc/qt/HTML"
+-addUninstallDir "/share/doc/qt"
+-addUninstallDir "/share/doc"
++addInstallDir "/share/help/en/backintime"
++addInstallFiles "docbook/en/*.docbook" "/share/help/en/backintime"
++addUninstallDir "/share/help/en"
++addUninstallDir "/share/help"
+ addNewline
+
+ addComment "man"
+ addInstallDir "/share/man/man1"
+-addInstallFile "man/C/backintime-qt.1.gz" "/share/man/man1"
++addInstallFile "man/C/backintime-qt.1" "/share/man/man1"
+ addUninstallDir "/share/man"
+ addNewline
+
+@@ -216,11 +203,6 @@ addUninstallDir "/share/icons"
+ addUninstallDir "/share"
+ addNewline
+
+-#compress
+-printf "compress:\n" >> ${MAKEFILE}
+-printf "\t#man pages\n" >> ${MAKEFILE}
+-printf "\tfor i in \$\$(ls -1 man/C/); do case \$\$i in *.gz|*~) continue;; *) gzip -n --best -c man/C/\$\$i > man/C/\$\${i}.gz;; esac; done\n\n" >> ${MAKEFILE}
+-
+ #uninstall
+ printf "uninstall: uninstall_files uninstall_dirs\n\n" >> ${MAKEFILE}
+ printf "uninstall_files:\n" >> ${MAKEFILE}
+--
+2.24.1
+