summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/boxbackup/boxbackup-0.11.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/boxbackup/boxbackup-0.11.1.ebuild')
-rw-r--r--app-backup/boxbackup/boxbackup-0.11.1.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/app-backup/boxbackup/boxbackup-0.11.1.ebuild b/app-backup/boxbackup/boxbackup-0.11.1.ebuild
new file mode 100644
index 000000000000..55bf9cb51035
--- /dev/null
+++ b/app-backup/boxbackup/boxbackup-0.11.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils user
+
+DESCRIPTION="A completely automatic on-line backup system"
+HOMEPAGE="http://boxbackup.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://boxbackup.org/svn/box/packages/${P/_/}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~ppc-macos ~x86-macos"
+IUSE="client-only"
+DEPEND="sys-libs/zlib
+ sys-libs/db
+ >=dev-libs/openssl-0.9.7
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+S="${WORKDIR}/${P/_/}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.11_rc8-testbbackupd.patch
+}
+
+src_compile() {
+ # bug #299411
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ emake -j1 DESTDIR="${D}" install-backup-client || die "client install failed"
+ use client-only || \
+ emake -j1 DESTDIR="${D}" install-backup-server || die "server install failed"
+
+ dodoc *.txt
+ newinitd "${FILESDIR}"/bbackupd.rc bbackupd
+ use client-only || \
+ newinitd "${FILESDIR}"/bbstored.rc bbstored
+
+ keepdir /etc/boxbackup
+
+ # apparently new versions have the files in the right location, so this is redundant
+ # move executables from /usr/bin to /usr/sbin, as configuration of
+ # this is unfortunately not optimal
+ #mv "${D%/}${EPREFIX}/usr/bin" "${D%/}${EPREFIX}/usr/sbin" || die "could not move files from bin to sbin"
+}
+
+pkg_preinst() {
+ if ! use client-only;
+ then
+ enewgroup bbstored
+ enewuser bbstored -1 -1 -1 bbstored
+ fi
+}
+
+pkg_postinst() {
+ while read line; do elog "${line}"; done <<EOF
+After configuring the Box Backup client and/or server, you can start
+the daemon using the init scripts /etc/init.d/bbackupd and
+/etc/init.d/bbstored.
+The configuration files can be found in /etc/boxbackup
+
+More information about configuring the client can be found at
+${HOMEPAGE}client.html,
+and more information about configuring the server can be found at
+${HOMEPAGE}server.html.
+EOF
+ echo
+}